summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-04-24 18:50:55 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-24 18:50:55 +0200
commit2dda3a7e38b518a9658ef776bcdaa72150e1c253 (patch)
tree2391a45c5f9c030bc0aff8cedc0ae99d79198965 /sys-firmware
parentsys-firmware/sgabios: EAPI 7 (diff)
downloadgentoo-2dda3a7e38b518a9658ef776bcdaa72150e1c253.tar.gz
gentoo-2dda3a7e38b518a9658ef776bcdaa72150e1c253.tar.bz2
gentoo-2dda3a7e38b518a9658ef776bcdaa72150e1c253.zip
sys-firmware/b43legacy-firmware: EAPI 7
Closes: https://bugs.gentoo.org/785271 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild b/sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild
index 3223244208f6..bd6e809ba086 100644
--- a/sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild
+++ b/sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild
@@ -1,37 +1,30 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-: ${B43_FIRMWARE_SRC_OBJ:=${A}}
-
-MY_P="broadcom-wl-${PV}"
DESCRIPTION="broadcom firmware for b43legacy/bcm43xx"
HOMEPAGE="http://linuxwireless.org/en/users/Drivers/b43"
SRC_URI="http://downloads.openwrt.org/sources/wl_apsta-${PV}.o"
-
-RESTRICT="binchecks bindist strip"
+S="${WORKDIR}"
LICENSE="Broadcom"
-SLOT=0
+SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND=">=net-wireless/b43-fwcutter-012"
+RESTRICT="binchecks bindist strip"
-S=${WORKDIR}
+BDEPEND=">=net-wireless/b43-fwcutter-012"
src_unpack() {
- cp "${DISTDIR}/${A}" "${WORKDIR}" || die
+ cp "${DISTDIR}/${A}" "${WORKDIR}/wl_apsta.o" || die
}
src_compile() {
- mkdir ebuild-output
- b43-fwcutter -w ebuild-output $(find -name ${B43_FIRMWARE_SRC_OBJ}) || die
+ mkdir ebuild-output || die
+ b43-fwcutter -w ebuild-output wl_apsta.o || die
}
src_install() {
insinto /lib/firmware
- doins -r ebuild-output/*
+ doins -r ebuild-output/.
}