summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrius Štikonas <andrius@stikonas.eu>2020-10-16 16:00:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-17 10:29:28 +0200
commitadcd978dd3638448314b1e49011cf07f832aca5f (patch)
treea60aa834c93af2bceee55345af3fe2d3154a7997 /sys-libs/kpmcore
parentdev-ml/ocaml-gettext: add missing dep(s) (diff)
downloadgentoo-adcd978dd3638448314b1e49011cf07f832aca5f.tar.gz
gentoo-adcd978dd3638448314b1e49011cf07f832aca5f.tar.bz2
gentoo-adcd978dd3638448314b1e49011cf07f832aca5f.zip
sys-libs/kpmcore: bump version to 4.2.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andrius Štikonas <andrius@stikonas.eu> Closes: https://github.com/gentoo/gentoo/pull/17949 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-libs/kpmcore')
-rw-r--r--sys-libs/kpmcore/Manifest1
-rw-r--r--sys-libs/kpmcore/kpmcore-4.2.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/kpmcore/Manifest b/sys-libs/kpmcore/Manifest
index 7635f849e871..ed6b10f51060 100644
--- a/sys-libs/kpmcore/Manifest
+++ b/sys-libs/kpmcore/Manifest
@@ -1 +1,2 @@
DIST kpmcore-4.1.0.tar.xz 420344 BLAKE2B 1a8043c5eb774a3b9b99431543217910120a38b06a17db9db9ae6c577593c2736223e8d466ef62c33224e52513eae52d062584fc8afd86d90eb667af4e923645 SHA512 c45b31a41c62a68aee991be0f7954f4bd2136660578cc60f7fa6f05e56716458421e16cd314b3b9a14b56fdc9377db511c1645e5c41f0446d86a8ac5bb66c273
+DIST kpmcore-4.2.0.tar.xz 441320 BLAKE2B 5eeae806e47a1d068b2052b7706fbe16acfd609e3d0bcb396758f2055154e43b5b1fc7b7a65795ba0804ebc34c7d0cda18995ce3975e16e74d015ac9d8203e1e SHA512 71c5411f3ec24149695bbc1ec0c2bb7423b1cfd24ea9c2f33492c6310b1e911ea14a0a46a53024d7a1afebf0cbc5b56fb7cf5be22b832fb49239a270b63404f0
diff --git a/sys-libs/kpmcore/kpmcore-4.2.0.ebuild b/sys-libs/kpmcore/kpmcore-4.2.0.ebuild
new file mode 100644
index 000000000000..4f02cda2f965
--- /dev/null
+++ b/sys-libs/kpmcore/kpmcore-4.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_NONGUI="true"
+KFMIN=5.74.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Library for managing partitions"
+HOMEPAGE="https://kde.org/applications/en/partitionmanager"
+
+LICENSE="GPL-3"
+SLOT="5/10"
+IUSE=""
+
+BDEPEND="
+ >=kde-frameworks/kauth-${KFMIN}:5
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=sys-apps/util-linux-2.33.2
+ sys-auth/polkit-qt
+"
+RDEPEND="${DEPEND}"
+
+# bug 689468, tests need polkit etc.
+RESTRICT+=" test"