summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-04 23:02:56 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-04 23:10:12 +0200
commitb235a2470ee34d41f4aa93bd7960a1d6297c7c68 (patch)
treecba06d89cb6e34ec210f5097ad2fb4d506be6069 /sys-libs/libcxx/libcxx-5.0.2.ebuild
parentmedia-libs/aubio: stable 0.4.7 for sparc, bug #667510 (diff)
downloadgentoo-b235a2470ee34d41f4aa93bd7960a1d6297c7c68.tar.gz
gentoo-b235a2470ee34d41f4aa93bd7960a1d6297c7c68.tar.bz2
gentoo-b235a2470ee34d41f4aa93bd7960a1d6297c7c68.zip
sys-libs/libcxx: Fix finding libsupc++ ABI headers for multilib
Fix the logic determining path to libsupc++ ABI headers to avoid being affected by CHOST alterations done as part of multilib logic. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/libcxx/libcxx-5.0.2.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-5.0.2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-libs/libcxx/libcxx-5.0.2.ebuild b/sys-libs/libcxx/libcxx-5.0.2.ebuild
index bd65e51b774b..eda78625c067 100644
--- a/sys-libs/libcxx/libcxx-5.0.2.ebuild
+++ b/sys-libs/libcxx/libcxx-5.0.2.ebuild
@@ -71,7 +71,9 @@ pkg_setup() {
fi
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -85,6 +87,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON