summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-29 19:09:14 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-29 19:13:55 +0100
commitf52f19cef8381e89c75d0318113b86d0ff23d34a (patch)
tree37f91f060b3c26adfcc29915e9771946056b0595 /sys-libs/libsmbios/libsmbios-2.4.1.ebuild
parentdev-go/go-crypto: Remove old version 0_pre20160126 (diff)
downloadgentoo-f52f19cef8381e89c75d0318113b86d0ff23d34a.tar.gz
gentoo-f52f19cef8381e89c75d0318113b86d0ff23d34a.tar.bz2
gentoo-f52f19cef8381e89c75d0318113b86d0ff23d34a.zip
sys-libs/libsmbios: Removed old
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libsmbios/libsmbios-2.4.1.ebuild')
-rw-r--r--sys-libs/libsmbios/libsmbios-2.4.1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/sys-libs/libsmbios/libsmbios-2.4.1.ebuild b/sys-libs/libsmbios/libsmbios-2.4.1.ebuild
deleted file mode 100644
index 158c4534ba3c..000000000000
--- a/sys-libs/libsmbios/libsmbios-2.4.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
-
-inherit autotools flag-o-matic python-single-r1 versionator
-
-DESCRIPTION="Provide access to (SM)BIOS information"
-HOMEPAGE="http://linux.dell.com/files/libsmbios/"
-SRC_URI="https://github.com/dell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 OSL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="doc graphviz nls python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="dev-libs/libxml2
- sys-libs/zlib
- nls? ( virtual/libintl )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- graphviz? ( media-gfx/graphviz )
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.9.6 )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.2.28-cppunit-tests.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Don't build yum-plugin - we don't need it
- sed '/yum-plugin/d' -i Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- #Remove -O3 for bug #290097
- replace-flags -O3 -O2
-
- local myeconfargs=(
- $(use_enable doc doxygen)
- $(use_enable graphviz)
- $(use_enable nls)
- $(use_enable python)
- $(use_enable static-libs static)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- if use python ; then
- python_scriptinto /usr/sbin
- python_doscript "${ED%/}"/usr/sbin/smbios-{{keyboard,thermal,token,wakeup,wireless}-ctl,lcd-brightness,passwd,sys-info}
- fi
-
- insinto /usr/include/
- doins -r src/include/smbios_c
-
- einstalldocs
-
- if ! use static-libs ; then
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
- fi
-}