summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-06 14:22:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-06 14:42:46 +0200
commitf4820d0562730c0e144c1bb98d2be040484cbac5 (patch)
treef072f2a563ddce77775ad5df3a5eb88e952dd7df /sys-libs/tevent/tevent-0.9.32.ebuild
parentsys-libs/libapparmor: remove libapparmor-2.11.0-r0 (diff)
downloadgentoo-f4820d0562730c0e144c1bb98d2be040484cbac5.tar.gz
gentoo-f4820d0562730c0e144c1bb98d2be040484cbac5.tar.bz2
gentoo-f4820d0562730c0e144c1bb98d2be040484cbac5.zip
sys-libs/tevent: Bump to version 0.9.32
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-libs/tevent/tevent-0.9.32.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.9.32.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-libs/tevent/tevent-0.9.32.ebuild b/sys-libs/tevent/tevent-0.9.32.ebuild
new file mode 100644
index 000000000000..6a12144b62e5
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.32.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.9[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}