summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-13 00:39:23 +0100
committerSam James <sam@gentoo.org>2022-10-13 00:39:23 +0100
commit24e01c69286c0aae15052c4c6bdf3efce8a2fa16 (patch)
tree0e1872f21f62105f28c5f8206e11c1c20460563a /sys-power
parentsys-power/tlp: new package, add 1.5.0 (diff)
downloadgentoo-24e01c69286c0aae15052c4c6bdf3efce8a2fa16.tar.gz
gentoo-24e01c69286c0aae15052c4c6bdf3efce8a2fa16.tar.bz2
gentoo-24e01c69286c0aae15052c4c6bdf3efce8a2fa16.zip
sys-power/tlp: tweak whitespace
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/tlp/tlp-1.5.0.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/sys-power/tlp/tlp-1.5.0.ebuild b/sys-power/tlp/tlp-1.5.0.ebuild
index 8eb8387f0e60..58c6a1db7a7d 100644
--- a/sys-power/tlp/tlp-1.5.0.ebuild
+++ b/sys-power/tlp/tlp-1.5.0.ebuild
@@ -6,24 +6,21 @@ EAPI=8
inherit udev optfeature
DESCRIPTION="Optimize laptop battery life"
-
HOMEPAGE="https://linrunner.de/tlp/"
-
SRC_URI="https://github.com/linrunner/TLP/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
S="${WORKDIR}/TLP-${PV}"
LICENSE="GPL-2"
-
SLOT="0"
-
KEYWORDS="~amd64"
# It's uncertain if elogind/systemd is actually required, however, without the sleep
# hooks working, which require one of them, it doesn't seem like this app is very useful.
-RDEPEND="virtual/udev
+RDEPEND="
dev-lang/perl
- || ( sys-auth/elogind sys-apps/systemd )"
+ virtual/udev
+ || ( sys-auth/elogind sys-apps/systemd )
+"
src_install() {
emake \
@@ -33,9 +30,9 @@ src_install() {
TLP_WITH_SYSTEMD=1 \
install install-man
- fperms 444 "/usr/share/tlp/defaults.conf" # manpage says this file should not be edited
+ fperms 444 /usr/share/tlp/defaults.conf # manpage says this file should not be edited
newinitd "${FILESDIR}/tlp.init" tlp
- keepdir "/var/lib/tlp" # created by Makefile, probably important
+ keepdir /var/lib/tlp # created by Makefile, probably important
}
pkg_postinst() {