summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-07-07 10:54:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-07-07 10:56:41 -0500
commit4f6f8132cce5369d5332a032ecce7dcea984ceda (patch)
tree38b33d1c1a1e39364b57400dcd9fa3ff8d14ebc7 /www-apps
parentwww-apps/icingaweb2: 2.11.1 bump (diff)
downloadgentoo-4f6f8132cce5369d5332a032ecce7dcea984ceda.tar.gz
gentoo-4f6f8132cce5369d5332a032ecce7dcea984ceda.tar.bz2
gentoo-4f6f8132cce5369d5332a032ecce7dcea984ceda.zip
www-apps/icingaweb2-module-director: 1.9.1 bump
Closes: https://bugs.gentoo.org/856679 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2-module-director/Manifest1
-rw-r--r--www-apps/icingaweb2-module-director/icingaweb2-module-director-1.9.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-director/Manifest b/www-apps/icingaweb2-module-director/Manifest
index 2c2b18489f72..499d19ecbf4e 100644
--- a/www-apps/icingaweb2-module-director/Manifest
+++ b/www-apps/icingaweb2-module-director/Manifest
@@ -1 +1,2 @@
DIST icingaweb2-module-director-1.8.1.tar.gz 3045604 BLAKE2B b94d870f23f6267250ed1b2165e0960e7a2f6df1b7545a7c22697af1fbc6ec0f0a7d04e92a410c33450613e95fca1c3dbb9db6f974d30a528856a60169a31bf2 SHA512 89fe35061deecd212576b6363289daa433c9664b95221c74a684a88e07ebd36d3b55b4a767f6caefeadb3679c5aa0787b1129f08b6d0fd698e5a2d5b17a3a2d1
+DIST icingaweb2-module-director-1.9.1.tar.gz 3095028 BLAKE2B 497dfc2f4a6f3f7f11c75dc4b934f54f4ff7e0644d97637bcd3a932e88e8bc719290b87be93ce15a6160966f8e1d959cfd6b150a9f630f13d6ea1e455753e776 SHA512 0fa0da31b1d8899ee127f6c2e6f4ee243dc21fc9516cec70a687a78188c84d0de4bddb1ad20e1b0c22200d4219407bc7d128be7063eeeb5e0eb48f0054846f79
diff --git a/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.9.1.ebuild b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.9.1.ebuild
new file mode 100644
index 000000000000..c9c0c1eaca8f
--- /dev/null
+++ b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Icinga Web 2 plugin for configuration"
+HOMEPAGE="https://dev.icinga.org/projects/icingaweb2-module-director/"
+inherit systemd
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-director.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-director"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.6.0
+ >=www-apps/icingaweb2-2.6.0
+ || (
+ dev-lang/php:7.3[curl,iconv,pcntl,posix,sockets]
+ dev-lang/php:7.4[curl,iconv,pcntl,posix,sockets]
+ dev-lang/php:8.0[curl,iconv,pcntl,posix,sockets]
+ )
+ acct-group/icingaweb2
+ acct-user/icingadirector"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/director/"
+ doins -r "${S}"/*
+ keepdir /var/lib/${PN}
+ fowners icingadirector:icingaweb2 /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+ sed -e "s|/usr/bin/icingacli|/usr/share/icingaweb2/bin/icingacli|g" \
+ contrib/systemd/icinga-director.service > "${T}/icinga-director.service" \
+ || die "failed to patch icinga-director.service"
+ systemd_dounit "${T}/icinga-director.service"
+}
+
+pkg_postinst() {
+ elog "Enable and start the icinga-director.service systemd service."
+}