summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-07-07 10:56:30 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-07-07 10:56:42 -0500
commit9ae235095d40d06efba654b7c94c3434b3028017 (patch)
tree7a93a5330b6cdce285c28cad81d68d1ccd75f537 /www-apps
parentwww-apps/icingaweb2-module-director: 1.9.1 bump (diff)
downloadgentoo-9ae235095d40d06efba654b7c94c3434b3028017.tar.gz
gentoo-9ae235095d40d06efba654b7c94c3434b3028017.tar.bz2
gentoo-9ae235095d40d06efba654b7c94c3434b3028017.zip
www-apps/icingaweb2-module-incubator: 0.17.0 bump
Closes: https://bugs.gentoo.org/856682 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2-module-incubator/Manifest1
-rw-r--r--www-apps/icingaweb2-module-incubator/icingaweb2-module-incubator-0.17.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-incubator/Manifest b/www-apps/icingaweb2-module-incubator/Manifest
index e64b530c115b..9ae67253f4b7 100644
--- a/www-apps/icingaweb2-module-incubator/Manifest
+++ b/www-apps/icingaweb2-module-incubator/Manifest
@@ -1 +1,2 @@
DIST icingaweb2-module-incubator-0.11.0.tar.gz 219239 BLAKE2B 32c194a4343dc706a56d86c8db33efc99cec3ee93d3929ee962f81623e2a4cd1277131ceae34c4f040ce1b69e4e1b004cc1202cb42639e25e56513e857b1292a SHA512 e8de6a685f87e70bfc689b0e2bd9fd8c1917996a43ed675399da0a6f6c208f062e20072338e329d57b507ac300ae59a1d18c23f0bd17d4394d2e3fef3b159cff
+DIST icingaweb2-module-incubator-0.17.0.tar.gz 222267 BLAKE2B e64942fe68d91ea720520bd8c8682328b9a78137e80726bb5bd563a98b809af1a0ec63cff753b955ef0b0f9af9c93389e90fd6bfe5d4eb531030ad6cbea6bc62 SHA512 711de5bde4681dd4d788165b4b1351c0eb4c61e417c6405bc0920ce0f4505fdc2167e070941708d4a19a0135fefd1accf1b5103d59367bef27bba87efe68285c
diff --git a/www-apps/icingaweb2-module-incubator/icingaweb2-module-incubator-0.17.0.ebuild b/www-apps/icingaweb2-module-incubator/icingaweb2-module-incubator-0.17.0.ebuild
new file mode 100644
index 000000000000..1a9efed8514f
--- /dev/null
+++ b/www-apps/icingaweb2-module-incubator/icingaweb2-module-incubator-0.17.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Libraries useful for Icinga Web 2"
+HOMEPAGE="https://dev.icinga.org/projects/icingaweb2-module-incubator/"
+KEYWORDS="~amd64 ~x86"
+MY_PN="icingaweb2-module-incubator"
+SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.6.0
+ >=www-apps/icingaweb2-2.6.0
+ || (
+ dev-lang/php:7.3[curl]
+ dev-lang/php:7.4[curl]
+ dev-lang/php:8.0[curl]
+ )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/incubator/"
+ doins -r "${S}"/*
+}