summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-08-25 16:26:37 -0400
committerMike Gilbert <floppym@gentoo.org>2018-08-25 16:26:55 -0400
commite5f6bd220d80055d4706b3832f0452d7ed18509c (patch)
treeb8d63688b9ef304432675be8060621ec9eb13879 /www-client/chromium
parentapp-i18n/fcitx: Remove dep on removed qt4 (diff)
downloadgentoo-e5f6bd220d80055d4706b3832f0452d7ed18509c.tar.gz
gentoo-e5f6bd220d80055d4706b3832f0452d7ed18509c.tar.bz2
gentoo-e5f6bd220d80055d4706b3832f0452d7ed18509c.zip
www-client/chromium: restore pax-mark of intermediate targets
Closes: https://bugs.gentoo.org/661282 Package-Manager: Portage-2.3.47, Repoman-2.3.10_p41
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-68.0.3440.106.ebuild12
-rw-r--r--www-client/chromium/chromium-68.0.3440.75.ebuild12
-rw-r--r--www-client/chromium/chromium-69.0.3497.42.ebuild12
-rw-r--r--www-client/chromium/chromium-70.0.3521.2.ebuild12
4 files changed, 48 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-68.0.3440.106.ebuild b/www-client/chromium/chromium-68.0.3440.106.ebuild
index 16791d0b40c5..50f8274850f9 100644
--- a/www-client/chromium/chromium-68.0.3440.106.ebuild
+++ b/www-client/chromium/chromium-68.0.3440.106.ebuild
@@ -583,6 +583,18 @@ src_compile() {
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
+ # Build mksnapshot and pax-mark it.
+ local x
+ for x in mksnapshot v8_context_snapshot_generator; do
+ if tc-is-cross-compiler; then
+ eninja -C out/Release "host/${x}"
+ pax-mark m "out/Release/host/${x}"
+ else
+ eninja -C out/Release "${x}"
+ pax-mark m "out/Release/${x}"
+ fi
+ done
+
# Even though ninja autodetects number of CPUs, we respect
# user's options, for debugging with -j 1 or any other reason.
eninja -C out/Release chrome chromedriver
diff --git a/www-client/chromium/chromium-68.0.3440.75.ebuild b/www-client/chromium/chromium-68.0.3440.75.ebuild
index 8585294049b0..3864487463f2 100644
--- a/www-client/chromium/chromium-68.0.3440.75.ebuild
+++ b/www-client/chromium/chromium-68.0.3440.75.ebuild
@@ -583,6 +583,18 @@ src_compile() {
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
+ # Build mksnapshot and pax-mark it.
+ local x
+ for x in mksnapshot v8_context_snapshot_generator; do
+ if tc-is-cross-compiler; then
+ eninja -C out/Release "host/${x}"
+ pax-mark m "out/Release/host/${x}"
+ else
+ eninja -C out/Release "${x}"
+ pax-mark m "out/Release/${x}"
+ fi
+ done
+
# Even though ninja autodetects number of CPUs, we respect
# user's options, for debugging with -j 1 or any other reason.
eninja -C out/Release chrome chromedriver
diff --git a/www-client/chromium/chromium-69.0.3497.42.ebuild b/www-client/chromium/chromium-69.0.3497.42.ebuild
index dcee9bd0f1c5..c3d05bb2729f 100644
--- a/www-client/chromium/chromium-69.0.3497.42.ebuild
+++ b/www-client/chromium/chromium-69.0.3497.42.ebuild
@@ -568,6 +568,18 @@ src_compile() {
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
+ # Build mksnapshot and pax-mark it.
+ local x
+ for x in mksnapshot v8_context_snapshot_generator; do
+ if tc-is-cross-compiler; then
+ eninja -C out/Release "host/${x}"
+ pax-mark m "out/Release/host/${x}"
+ else
+ eninja -C out/Release "${x}"
+ pax-mark m "out/Release/${x}"
+ fi
+ done
+
# Even though ninja autodetects number of CPUs, we respect
# user's options, for debugging with -j 1 or any other reason.
eninja -C out/Release chrome chromedriver
diff --git a/www-client/chromium/chromium-70.0.3521.2.ebuild b/www-client/chromium/chromium-70.0.3521.2.ebuild
index 953d96e54e41..c70f37c2a62f 100644
--- a/www-client/chromium/chromium-70.0.3521.2.ebuild
+++ b/www-client/chromium/chromium-70.0.3521.2.ebuild
@@ -573,6 +573,18 @@ src_compile() {
#"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
+ # Build mksnapshot and pax-mark it.
+ local x
+ for x in mksnapshot v8_context_snapshot_generator; do
+ if tc-is-cross-compiler; then
+ eninja -C out/Release "host/${x}"
+ pax-mark m "out/Release/host/${x}"
+ else
+ eninja -C out/Release "${x}"
+ pax-mark m "out/Release/${x}"
+ fi
+ done
+
# Even though ninja autodetects number of CPUs, we respect
# user's options, for debugging with -j 1 or any other reason.
eninja -C out/Release chrome chromedriver