summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-08 13:06:41 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-08 13:06:41 +0300
commit7428727ec9a808dc225e1c06d99ae4ee161f6f2d (patch)
tree457d6e78e2338cce6f3e0133e9711add923566f6 /www-client/epiphany
parentwww-client/epiphany: bump to 3.32.5 (diff)
downloadgentoo-7428727ec9a808dc225e1c06d99ae4ee161f6f2d.tar.gz
gentoo-7428727ec9a808dc225e1c06d99ae4ee161f6f2d.tar.bz2
gentoo-7428727ec9a808dc225e1c06d99ae4ee161f6f2d.zip
www-client/epiphany: bump to 3.30.5
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.30.5.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 2296bbabf46f..545cef0bec97 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,3 +1,4 @@
DIST epiphany-3.30.4.tar.xz 4531732 BLAKE2B a4741d353800517c0233456e513a974ecd7641799395df7cafe6940cbfa49402836484010634ef3c59e36bd3bb2ced331d19a4ed05d1630c00d7ee385961227b SHA512 8574a26a22a24db7e65254f65723f6e4405fccd783bb7e122f8a5f6aff62d3ef1dd0b3ce903eb1f750e7ae28c2f1154a2c1c15970892216211d51edee318bd47
+DIST epiphany-3.30.5.tar.xz 4532136 BLAKE2B 7c42e7ff5624bd85c380da97b2ca057b59d4dc77bec85f33bab755032b519db10ee52aa93c503e5b1f57c5acfce5a9b3decc7dddfacc3d68ea620eb884ec2da3 SHA512 1d31022e91a5ac79a032ebf988d4f8828cfa38a2b67e06b9432e479d7ebc93d3a08338261b92dfe3f37b6f745aeb5286b4acc65c537d935c1ace61ad9a494b7d
DIST epiphany-3.32.4.tar.xz 5468576 BLAKE2B 8d9ed9f522a7f18c1e9b0fa6aea043c11e69eda8ee779e8cb05cbef1920154ee7e307ea92eac713c74f7a81a08d9fc31dfd3ba8fad59d5697f4aa652e12a6e8e SHA512 34f9f4267862b494cbeb225ce63cd7767851f1cca16b4c8e03057b074999954477f2ed891c60f20910abcc7a553371f8f03e59fc9da4cf459dd5cbfde8a6d67c
DIST epiphany-3.32.5.tar.xz 5468976 BLAKE2B 7e15eccbf48e7d2ada7b7a4ee4643219149f0d81c8c1767e5871fbed023bf53cd548822eabe5c9e0a26fd62a255ec69efdbd5efd05faef0e0374cedb473f5978 SHA512 e14a2626071460ddf8493a765d877f7683ba51e572778bb03f83ce31170856c6de91327955bd2d3b43e9016457da35a966014019d8837cd85765f948a7d1e5d2
diff --git a/www-client/epiphany/epiphany-3.30.5.ebuild b/www-client/epiphany/epiphany-3.30.5.ebuild
new file mode 100644
index 000000000000..8541b4a1ffde
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.30.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.52.0:2
+ >=x11-libs/gtk+-3.22.13:3
+ >=dev-libs/nettle-3.2:=
+ >=net-libs/webkit-gtk-2.21.92:4=
+ >=x11-libs/cairo-1.2
+ >=dev-libs/libdazzle-3.28.0
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ dev-libs/icu:=
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.14
+ >=net-libs/libsoup-2.48:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ dev-db/sqlite:3
+ dev-libs/gmp:0=
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# paxctl needed for bug #407085
+# appstream-glib needed for appdata.xml gettext translation
+DEPEND="${COMMON_DEPEND}
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-apps/paxctl
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Ddistributor_name=Gentoo
+ -Dtech_preview=false
+ $(meson_use test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}