summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaximilian Friedersdorff <max@friedersdorff.com>2019-02-14 10:55:15 +0000
committerJustin Bronder <jsbronder@gentoo.org>2019-03-11 10:10:24 -0400
commitddd3840a7b57e788682771b2b769608d0aa848b5 (patch)
treed3b563606a43da47bdbe7418a3fd877ce75e0156 /www-client/qutebrowser
parentmedia-sound/seq24: Add missing eautoreconf (diff)
downloadgentoo-ddd3840a7b57e788682771b2b769608d0aa848b5.tar.gz
gentoo-ddd3840a7b57e788682771b2b769608d0aa848b5.tar.bz2
gentoo-ddd3840a7b57e788682771b2b769608d0aa848b5.zip
www-client/qutebrowser: Add scripts use flag
Closes: https://bugs.gentoo.org/622980 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Maximilian Friedersdorff <max@friedersdorff.com> Signed-off-by: Justin Bronder <jsbronder@gentoo.org>
Diffstat (limited to 'www-client/qutebrowser')
-rw-r--r--www-client/qutebrowser/metadata.xml4
-rw-r--r--www-client/qutebrowser/qutebrowser-1.5.2-r1.ebuild13
-rw-r--r--www-client/qutebrowser/qutebrowser-1.6.0.ebuild13
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild13
4 files changed, 40 insertions, 3 deletions
diff --git a/www-client/qutebrowser/metadata.xml b/www-client/qutebrowser/metadata.xml
index 7623d04971cf..3c4b9436adf9 100644
--- a/www-client/qutebrowser/metadata.xml
+++ b/www-client/qutebrowser/metadata.xml
@@ -12,4 +12,8 @@
<upstream>
<remote-id type="github">qutebrowser/qutebrowser</remote-id>
</upstream>
+ <use>
+ <flag name="scripts">Installs userscripts from the misc/userscripts
+ directory to /usr/share/qutebrowser/userscripts.</flag>
+ </use>
</pkgmetadata>
diff --git a/www-client/qutebrowser/qutebrowser-1.5.2-r1.ebuild b/www-client/qutebrowser/qutebrowser-1.5.2-r1.ebuild
index 9870584a71be..a464d065fdc3 100644
--- a/www-client/qutebrowser/qutebrowser-1.5.2-r1.ebuild
+++ b/www-client/qutebrowser/qutebrowser-1.5.2-r1.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowse
LICENSE="GPL-3"
SLOT="0"
-IUSE="test"
+IUSE="scripts test"
COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${COMMON_DEPEND}
@@ -55,6 +55,17 @@ python_install_all() {
domenu misc/${PN}.desktop
doicon -s scalable icons/${PN}.svg
+ if use scripts; then
+ # Install only those userscripts that have an explicit license header
+ exeinto /usr/share/qutebrowser/userscripts/
+ doexe misc/userscripts/dmenu_qutebrowser
+ doexe misc/userscripts/openfeeds
+ doexe misc/userscripts/qute-keepass
+ doexe misc/userscripts/qute-pass
+ doexe misc/userscripts/rss
+ doexe misc/userscripts/tor_identity
+ fi
+
distutils-r1_python_install_all
}
diff --git a/www-client/qutebrowser/qutebrowser-1.6.0.ebuild b/www-client/qutebrowser/qutebrowser-1.6.0.ebuild
index 9870584a71be..a464d065fdc3 100644
--- a/www-client/qutebrowser/qutebrowser-1.6.0.ebuild
+++ b/www-client/qutebrowser/qutebrowser-1.6.0.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowse
LICENSE="GPL-3"
SLOT="0"
-IUSE="test"
+IUSE="scripts test"
COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${COMMON_DEPEND}
@@ -55,6 +55,17 @@ python_install_all() {
domenu misc/${PN}.desktop
doicon -s scalable icons/${PN}.svg
+ if use scripts; then
+ # Install only those userscripts that have an explicit license header
+ exeinto /usr/share/qutebrowser/userscripts/
+ doexe misc/userscripts/dmenu_qutebrowser
+ doexe misc/userscripts/openfeeds
+ doexe misc/userscripts/qute-keepass
+ doexe misc/userscripts/qute-pass
+ doexe misc/userscripts/rss
+ doexe misc/userscripts/tor_identity
+ fi
+
distutils-r1_python_install_all
}
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 106757922792..67471c02f629 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowse
LICENSE="GPL-3"
SLOT="0"
-IUSE="test"
+IUSE="scripts test"
COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${COMMON_DEPEND}
@@ -55,6 +55,17 @@ python_install_all() {
domenu misc/org.${PN}.${PN}.desktop
doicon -s scalable icons/${PN}.svg
+ if use scripts; then
+ # Install only those userscripts that have an explicit license header
+ exeinto /usr/share/qutebrowser/userscripts/
+ doexe misc/userscripts/dmenu_qutebrowser
+ doexe misc/userscripts/openfeeds
+ doexe misc/userscripts/qute-keepass
+ doexe misc/userscripts/qute-pass
+ doexe misc/userscripts/rss
+ doexe misc/userscripts/tor_identity
+ fi
+
distutils-r1_python_install_all
}