summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-19 12:33:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-19 12:33:00 +0100
commit007e6e11f29ca44a31c3c21f7ca739e5aade419a (patch)
treeacb9b7e59f3b90bd0bc28f7a6429b0c27d1816ef /www-client
parentwww-client/weboob: 1.3 version bump (diff)
downloadgentoo-007e6e11f29ca44a31c3c21f7ca739e5aade419a.tar.gz
gentoo-007e6e11f29ca44a31c3c21f7ca739e5aade419a.tar.bz2
gentoo-007e6e11f29ca44a31c3c21f7ca739e5aade419a.zip
www-client/weboob: Drop very old versions 0g, 0h
These versions reportedly do not work anymore, anyway, and still depended on deprecated PyQt4. Bug: https://bugs.gentoo.org/510810 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'www-client')
-rw-r--r--www-client/weboob/Manifest2
-rw-r--r--www-client/weboob/weboob-0g.ebuild79
-rw-r--r--www-client/weboob/weboob-0h.ebuild79
3 files changed, 0 insertions, 160 deletions
diff --git a/www-client/weboob/Manifest b/www-client/weboob/Manifest
index 848c92bf0a38..2d89b0fcd56a 100644
--- a/www-client/weboob/Manifest
+++ b/www-client/weboob/Manifest
@@ -1,3 +1 @@
-DIST weboob-0.g.tar.gz 1465176 BLAKE2B 8b6efeb14e2233957844319de55c3f78665f89f95e88017bbbec983d1dc9525035a5d83fe5465d817d75267b1a8e5abcda5f0bc2c8c687100194f5c1d49ec03b SHA512 802b0f4cb10d1c2a13dc183d59aa642a9642b3b8f9417ce7bf66835a5f7028bc3fde9a8f3048b01cd5601585d37e6c95fa277b768723d05ab1b8eb4cb74a40bc
-DIST weboob-0.h.tar.gz 1700259 BLAKE2B e6971c8b498dd0478177334c42a39e871ee79c0171e33e7e7c8401cebfe7ea38dd7ca013b6eaa705ba5e422cf55292b8db8bc5deddce007827b3ef3af3ec7c0f SHA512 9ec34d184f965ec9124e7cb7e40e9337f781e2d79171fdc2f48b20d68bc21b8cabb349b56229b97f86257edb1d9f24886cbe3576a0fc80ed4440168119ea7e2b
DIST weboob-1.3.tar.gz 2688899 BLAKE2B a75a854137b117fd228959a6c5d19e93c5a0520a8e88227e2d6e8bf13795b2d3ba51173307563b5704be68fe680dd3573fc3b7308e29d422bc9ee6e3d4adaaa7 SHA512 c56704b9fc0d21c5d2b4d297f677f01d25d523c3d45acf7ed0b241fccd4b2477ddb60e58d2dd68886858dc8a50faa43d533c808b106546180552babf9c07543c
diff --git a/www-client/weboob/weboob-0g.ebuild b/www-client/weboob/weboob-0g.ebuild
deleted file mode 100644
index 8cc40ca6189f..000000000000
--- a/www-client/weboob/weboob-0g.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 2010-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 gnome2-utils versionator
-
-if [ "$PV" == "9999" ]; then
- EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/devel.git"
- inherit git-2
- KEYWORDS=""
- SRC_URI=""
-elif [ "$PV" == "9998" ]; then
- EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/stable.git"
- inherit git-2
- KEYWORDS=""
- SRC_URI=""
-else
- KEYWORDS="~x86 ~amd64"
- MY_P="${PN}-$(version_format_string '$1.$2')"
- SRC_URI="http://symlink.me/attachments/download/229/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-fi
-
-DESCRIPTION="Consume lots of websites without a browser (Web Outside Of Browsers)"
-HOMEPAGE="http://weboob.org/"
-
-LICENSE="AGPL-3"
-SLOT="0"
-IUSE="X +secure-updates fast-libs"
-
-DEPEND="X? ( >=dev-python/PyQt4-4.9.4-r1[X,phonon,${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- dev-python/prettytable[${PYTHON_USEDEP}]
- dev-python/html2text[${PYTHON_USEDEP}]
- dev-python/mechanize[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/gdata[${PYTHON_USEDEP}]
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/termcolor[${PYTHON_USEDEP}]
- secure-updates? ( app-crypt/gnupg )
- fast-libs? (
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
- )
- >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]"
-
-DOCS=( AUTHORS COPYING ChangeLog README INSTALL )
-
-python_configure_all() {
- mydistutilsargs=(
- $(usex X '--qt' '--no-qt')
- $(usex X '--xdg' '--no-xdg')
- )
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- insinto /usr/share/${PN}/
- doins -r contrib/*
-}
-
-pkg_preinst() {
- use X && gnome2_icon_savelist
-}
-
-pkg_postinst() {
- use X && gnome2_icon_cache_update
- elog 'You should now run "weboob-config update" (as your login user).'
-}
-
-pkg_postrm() {
- use X && gnome2_icon_cache_update
-}
diff --git a/www-client/weboob/weboob-0h.ebuild b/www-client/weboob/weboob-0h.ebuild
deleted file mode 100644
index d3f6230fa0ec..000000000000
--- a/www-client/weboob/weboob-0h.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 2010-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 gnome2-utils versionator
-
-if [ "$PV" == "9999" ]; then
- EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/devel.git"
- inherit git-2
- KEYWORDS=""
- SRC_URI=""
-elif [ "$PV" == "9998" ]; then
- EGIT_REPO_URI="git://git.symlink.me/pub/${PN}/stable.git"
- inherit git-2
- KEYWORDS=""
- SRC_URI=""
-else
- KEYWORDS="~x86 ~amd64"
- MY_P="${PN}-$(version_format_string '$1.$2')"
- SRC_URI="http://symlink.me/attachments/download/235/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-fi
-
-DESCRIPTION="Consume lots of websites without a browser (Web Outside Of Browsers)"
-HOMEPAGE="http://weboob.org/"
-
-LICENSE="AGPL-3"
-SLOT="0"
-IUSE="X +secure-updates fast-libs"
-
-DEPEND="X? ( >=dev-python/PyQt4-4.9.4-r1[X,phonon,${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- dev-python/prettytable[${PYTHON_USEDEP}]
- dev-python/html2text[${PYTHON_USEDEP}]
- dev-python/mechanize[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/gdata[${PYTHON_USEDEP}]
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/termcolor[${PYTHON_USEDEP}]
- secure-updates? ( app-crypt/gnupg )
- fast-libs? (
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
- )
- >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]"
-
-DOCS=( AUTHORS COPYING ChangeLog README INSTALL )
-
-python_configure_all() {
- mydistutilsargs=(
- $(usex X '--qt' '--no-qt')
- $(usex X '--xdg' '--no-xdg')
- )
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- insinto /usr/share/${PN}/
- doins -r contrib/*
-}
-
-pkg_preinst() {
- use X && gnome2_icon_savelist
-}
-
-pkg_postinst() {
- use X && gnome2_icon_cache_update
- elog 'You should now run "weboob-config update" (as your login user).'
-}
-
-pkg_postrm() {
- use X && gnome2_icon_cache_update
-}