summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDarkDefender <darkdefende@gmail.com>2019-12-29 15:30:43 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-03 11:14:26 +0200
commitac3158ef82f8d6d80e87a1cb9bfe6b5d2633c669 (patch)
tree15c46f21c79d0023bd65d881ea00ec0915d89cd9 /www-client
parentapp-i18n/translate-shell: bump version to 0.9.6.11 (diff)
downloadgentoo-ac3158ef82f8d6d80e87a1cb9bfe6b5d2633c669.tar.gz
gentoo-ac3158ef82f8d6d80e87a1cb9bfe6b5d2633c669.tar.bz2
gentoo-ac3158ef82f8d6d80e87a1cb9bfe6b5d2633c669.zip
www-client/qutebrowser: Fix live ebuild .desktop generation
The live ebuild recently stopped producing `.desktop` files. Therefore qutebrowser did have any start menu entries. I've just synced the code that is responsible for this with the non live ebuild. It seems to work fine. Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14168 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 4786a63c56fb..2243e4e7da93 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python{3_5,3_6,3_7} )
-inherit distutils-r1 eutils xdg-utils
+inherit desktop distutils-r1 eutils xdg-utils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
@@ -77,12 +77,12 @@ python_install_all() {
pkg_postinst() {
optfeature "PDF display support" www-plugins/pdfjs
xdg_desktop_database_update
+ xdg_icon_cache_update
xdg_mimeinfo_database_update
- gnome2_icon_cache_update
}
pkg_postrm() {
xdg_desktop_database_update
+ xdg_icon_cache_update
xdg_mimeinfo_database_update
- gnome2_icon_cache_update
}