summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-27 17:18:54 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-27 17:19:12 +0100
commit0c6d92e104174577fd9ae2e857c0c27cbcfe7f3d (patch)
tree315376f8bd85acd5c4e3fc7930aaa34519594d6e /www-servers/pshs/pshs-0.3.3.ebuild
parentkde-apps/kdecore-meta: Add falkon as alt. web browser (diff)
downloadgentoo-0c6d92e104174577fd9ae2e857c0c27cbcfe7f3d.tar.gz
gentoo-0c6d92e104174577fd9ae2e857c0c27cbcfe7f3d.tar.bz2
gentoo-0c6d92e104174577fd9ae2e857c0c27cbcfe7f3d.zip
www-servers/pshs: Bump to 0.3.3
Bump to new 0.3.3 release that fixes OpenSSL-1.1 compatibility (thanks, Quentin!) and linking to new libnetlink. Closes: https://bugs.gentoo.org/648910
Diffstat (limited to 'www-servers/pshs/pshs-0.3.3.ebuild')
-rw-r--r--www-servers/pshs/pshs-0.3.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-servers/pshs/pshs-0.3.3.ebuild b/www-servers/pshs/pshs-0.3.3.ebuild
new file mode 100644
index 000000000000..cafb509f3846
--- /dev/null
+++ b/www-servers/pshs/pshs-0.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/mgorny/pshs/"
+SRC_URI="https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2[-minimal]
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ local myconf=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ econf "${myconf[@]}"
+}