summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-02 01:55:05 +0200
committerMatt Turner <mattst88@gentoo.org>2021-05-02 11:24:45 -0400
commitec75c0aaa37fb73bb5dd3ced5d11e8ba7fb13f0a (patch)
tree14ade2f12f3e2aaf9e8ee0bf101a95ec0c26a643 /x11-drivers
parentx11-drivers/xf86-video-amdgpu: Define XORG_CONFIGURE_OPTIONS in src_configure (diff)
downloadgentoo-ec75c0aaa37fb73bb5dd3ced5d11e8ba7fb13f0a.tar.gz
gentoo-ec75c0aaa37fb73bb5dd3ced5d11e8ba7fb13f0a.tar.bz2
gentoo-ec75c0aaa37fb73bb5dd3ced5d11e8ba7fb13f0a.zip
x11-drivers/xf86-video-ati: Define XORG_CONFIGURE_OPTIONS in src_configure
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild12
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild12
2 files changed, 18 insertions, 6 deletions
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild
index 8949920fd61b..70b6b7db0934 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,7 +29,7 @@ PATCHES=(
)
pkg_pretend() {
- if use kernel_linux ; then
+ if use kernel_linux; then
if kernel_is -ge 3 9; then
CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
else
@@ -40,8 +40,14 @@ pkg_pretend() {
}
pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+ linux-info_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--enable-glamor
$(use_enable udev)
)
+ xorg-3_src_configure
}
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
index 2aab4b2d7290..0d96979995e8 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,7 @@ DEPEND="${RDEPEND}
x11-base/xorg-proto"
pkg_pretend() {
- if use kernel_linux ; then
+ if use kernel_linux; then
if kernel_is -ge 3 9; then
CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
else
@@ -36,8 +36,14 @@ pkg_pretend() {
}
pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+ linux-info_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--enable-glamor
$(use_enable udev)
)
+ xorg-3_src_configure
}