summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-04-02 15:36:32 -0700
committerMatt Turner <mattst88@gentoo.org>2018-04-02 15:43:53 -0700
commit2fa1a1fa049071b0ea98d1ced640bcc4c0e2c864 (patch)
tree1c6ac22d5454aa262345f42794cfe023aa09fb6f /x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild
parentsys-apps/agedu: version bump to 20180329 (diff)
downloadgentoo-2fa1a1fa049071b0ea98d1ced640bcc4c0e2c864.tar.gz
gentoo-2fa1a1fa049071b0ea98d1ced640bcc4c0e2c864.tar.bz2
gentoo-2fa1a1fa049071b0ea98d1ced640bcc4c0e2c864.zip
x11-libs/xcb-util-xrm: Version bump to 1.3
Also depend on libX11 unconditionally, for bug linked below. Closes: https://bugs.gentoo.org/651016
Diffstat (limited to 'x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild')
-rw-r--r--x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild
new file mode 100644
index 000000000000..1390d9435c5f
--- /dev/null
+++ b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_BASE_INDIVIDUAL_URI=""
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/"
+SRC_URI="https://github.com/Airblader/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-libs/libX11[${MULTILIB_USEDEP}]" # Only for tests, but configure.ac requires it
+
+src_configure() {
+ xorg-2_src_configure
+}