summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/asapm/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/asapm/files')
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-autoconf.patch21
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-include.patch10
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-ldflags.patch11
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-plugins/asapm/files/asapm-3.1-autoconf.patch b/x11-plugins/asapm/files/asapm-3.1-autoconf.patch
new file mode 100644
index 000000000000..0051d49ac8a8
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-autoconf.patch
@@ -0,0 +1,21 @@
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -59,7 +59,6 @@
+ AC_CHECK_HEADERS(sys/wait.h sys/time.h)
+ AC_CHECK_HEADERS(sys/statvfs.h sys/vfs.h sys/mount.h ustat.h)
+ AC_CHECK_HEADERS(machine/soundcard.h linux/soundcard.h linux/radio.h)
+-AC_CONFIG_HEADER(config.h)
+
+ dnl# Check for X
+
+@@ -117,10 +116,6 @@
+ AC_SUBST(with_gnustep_lib)
+ AC_SUBST(with_afterdir)
+
+-dnl# Write results
+-
+-AC_CONFIG_HEADER(config.h)
+-
+ dnl# Common parts of the Makefile
+ MAKEFILEDEFINES=./autoconf/Makefile.defines
+ MAKEFILECOMMON=./autoconf/Makefile.common
diff --git a/x11-plugins/asapm/files/asapm-3.1-include.patch b/x11-plugins/asapm/files/asapm-3.1-include.patch
new file mode 100644
index 000000000000..529d994ef122
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-include.patch
@@ -0,0 +1,10 @@
+--- a/apm_read.c
++++ b/apm_read.c
+@@ -13,6 +13,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h> /* exit(), free() */
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <unistd.h>
diff --git a/x11-plugins/asapm/files/asapm-3.1-ldflags.patch b/x11-plugins/asapm/files/asapm-3.1-ldflags.patch
new file mode 100644
index 000000000000..a90d7baf2e4e
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/autoconf/Makefile.common.in
++++ b/autoconf/Makefile.common.in
+@@ -34,7 +34,7 @@
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(LDFLAGS) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c