summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 14:52:03 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-07-26 22:30:52 +0200
commit07b5fd136fac50a329f38d071cefc89a11efd109 (patch)
tree50453a3c5f22c59428c5bd8d51531f5ced3717e1 /x11-plugins
parentx11-plugins/wmfrog: EAPI7, improve ebuild (diff)
downloadgentoo-07b5fd136fac50a329f38d071cefc89a11efd109.tar.gz
gentoo-07b5fd136fac50a329f38d071cefc89a11efd109.tar.bz2
gentoo-07b5fd136fac50a329f38d071cefc89a11efd109.zip
x11-plugins/wmfsm: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfsm/wmfsm-0.36-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/wmfsm/wmfsm-0.36-r1.ebuild b/x11-plugins/wmfsm/wmfsm-0.36-r1.ebuild
new file mode 100644
index 000000000000..c350aba89612
--- /dev/null
+++ b/x11-plugins/wmfsm/wmfsm-0.36-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="dockapp for monitoring filesystem usage"
+HOMEPAGE="https://www.dockapps.net/wmfsm"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ sed -e "/^X11LIBS/s/-I$x_includes //" -i configure.ac || die "sed failed"
+
+ eautoreconf
+}