summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-22 19:27:03 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:15:40 +0200
commita1f690a936492d650e80e9bbddaa387be8e157a9 (patch)
treeaade6f38dad1ca93f8302ab29cf77e1c2b068a7a /x11-plugins
parentx11-plugins/wmload: EAPI7, improve ebuild (diff)
downloadgentoo-a1f690a936492d650e80e9bbddaa387be8e157a9.tar.gz
gentoo-a1f690a936492d650e80e9bbddaa387be8e157a9.tar.bz2
gentoo-a1f690a936492d650e80e9bbddaa387be8e157a9.zip
x11-plugins/wmmenu: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmenu/files/wmmenu-1.3-Makefile.patch4
-rw-r--r--x11-plugins/wmmenu/wmmenu-1.3-r2.ebuild38
2 files changed, 40 insertions, 2 deletions
diff --git a/x11-plugins/wmmenu/files/wmmenu-1.3-Makefile.patch b/x11-plugins/wmmenu/files/wmmenu-1.3-Makefile.patch
index a6fc4c7ec437..bbf18433480c 100644
--- a/x11-plugins/wmmenu/files/wmmenu-1.3-Makefile.patch
+++ b/x11-plugins/wmmenu/files/wmmenu-1.3-Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2015-04-17 13:43:08.122972280 +0200
-+++ Makefile 2015-04-17 13:43:11.569975854 +0200
+--- a/Makefile 2015-04-17 13:43:08.122972280 +0200
++++ b/Makefile 2015-04-17 13:43:11.569975854 +0200
@@ -14,12 +14,12 @@
PIXBUF_LIB := -rdynamic -L$(shell $(PIXBUF_CFG) --variable=prefix)/lib -lgdk_pixbuf_xlib-2.0 -lgdk_pixbuf-2.0 -lgobject-2.0
endif
diff --git a/x11-plugins/wmmenu/wmmenu-1.3-r2.ebuild b/x11-plugins/wmmenu/wmmenu-1.3-r2.ebuild
new file mode 100644
index 000000000000..ab02ed5b392d
--- /dev/null
+++ b/x11-plugins/wmmenu/wmmenu-1.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="a popup menu of icons like in AfterStep, as a dockapp"
+HOMEPAGE="https://www.dockapps.net/wmmenu"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/gdk-pixbuf[X]
+ >=x11-libs/libdockapp-0.7:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/dockapps"
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+DOCS=( README TODO example/{apps,defaults,extract_icon_back} )
+
+src_prepare() {
+ default
+ sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wmmenu
+ doman wmmenu.1
+ einstalldocs
+}