summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:21:38 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:15 +0100
commitf64874060f2bfc9990d93d6d0f7144d7db49122a (patch)
tree70dceccb38c8a7a30356b60a7196b77a5c35020c /x11-plugins
parentx11-plugins/bfm: tidy patch (diff)
downloadgentoo-f64874060f2bfc9990d93d6d0f7144d7db49122a.tar.gz
gentoo-f64874060f2bfc9990d93d6d0f7144d7db49122a.tar.bz2
gentoo-f64874060f2bfc9990d93d6d0f7144d7db49122a.zip
x11-plugins/bubblemon: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild19
-rw-r--r--x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch4
2 files changed, 12 insertions, 11 deletions
diff --git a/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild b/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild
index 196a466da0e0..ba410ab76f8e 100644
--- a/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild
+++ b/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild
@@ -1,30 +1,31 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="A fun monitoring applet for your desktop, complete with swimming duck"
HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${PN}-dockapp-${PV}.tar.gz"
+S="${WORKDIR}"/${PN}-dockapp-${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE=""
RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${PN}-dockapp-${PV}
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${P}-gtk.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-gtk.patch
"${FILESDIR}"/${P}-asneeded.patch
- "${FILESDIR}"/${P}-no_display.patch )
+ "${FILESDIR}"/${P}-no_display.patch
+)
src_compile() {
- tc-export CC
+ tc-export CC PKG_CONFIG
emake GENTOO_CFLAGS="${CFLAGS}"
}
diff --git a/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch b/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
index 5a57624061c2..8b895c0e3b53 100644
--- a/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
+++ b/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
@@ -40,8 +40,8 @@
# no user serviceable parts below
EXTRA += $(WMAN)
+# gtk cflags and gtk lib flags
-+GTK2_CFLAGS = $(shell pkg-config gtk+-2.0 --cflags)
-+GTK2_LIBS = $(shell pkg-config gtk+-2.0 --libs)
++GTK2_CFLAGS = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK2_LIBS = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+
+
# optimization cflags