summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2020-10-14 21:09:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-17 17:04:37 +0300
commit300c582e39d7ce33461b29da6c825fa8899d17b1 (patch)
treeac88ebad29afef64367c411e39c9788df0ad0356 /x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild
parentx11-terms/kitty: bump to 0.19.1 and fix tests (diff)
downloadgentoo-300c582e39d7ce33461b29da6c825fa8899d17b1.tar.gz
gentoo-300c582e39d7ce33461b29da6c825fa8899d17b1.tar.bz2
gentoo-300c582e39d7ce33461b29da6c825fa8899d17b1.zip
x11-terms/kitty-terminfo: bump to 0.19.1
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17930 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild
new file mode 100644
index 000000000000..cc2defc98684
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.19.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.19.1.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}