summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/yeahconsole/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/yeahconsole/files')
-rw-r--r--x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
new file mode 100644
index 000000000000..0075c433292b
--- /dev/null
+++ b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
@@ -0,0 +1,30 @@
+--- a/Makefile 2006-01-14 16:54:05.000000000 +0100
++++ b/Makefile 2009-02-26 16:18:25.000000000 +0100
+@@ -1,6 +1,4 @@
+ TARGET = yeahconsole
+-CC = gcc
+-#CC = cc
+ INSTALL = install
+
+ PREFIX = /usr/local
+@@ -8,17 +6,16 @@
+ LIBS = -lX11
+ INCLUDES = -I/usr/X11R6/include
+ LIB_DIRS = -L/usr/X11R6/lib
+-FLAGS = -Os -Wall
++FLAGS = -Wall $(CFLAGS)
+
+ OBJECTS := yeahconsole.o
+ SOURCES := yeahconsole.c
+
+ $(TARGET): $(OBJECTS)
+- $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
+- strip $@
++ $(CC) $(FLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -o $@ $< $(LIBS)
+
+ $(OBJECTS): $(SOURCES)
+- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
++ $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
+
+ clean:
+ rm -rf $(TARGET) $(OBJECTS)