summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-12-03 13:26:20 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-12-03 13:26:31 +0300
commit4e31732cf4886447fbe2915a211adaa9014411d4 (patch)
treef27baf5a77b8fd0ab6a2ccab8a016894e7d51cef /x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild
parentdev-python/tox: Fix missing revision in self-dep (diff)
downloadgentoo-4e31732cf4886447fbe2915a211adaa9014411d4.tar.gz
gentoo-4e31732cf4886447fbe2915a211adaa9014411d4.tar.bz2
gentoo-4e31732cf4886447fbe2915a211adaa9014411d4.zip
x11-themes/papirus-icon-theme: Version bump (v20191201)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild')
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild
new file mode 100644
index 000000000000..8afbb557b0ce
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils
+
+DESCRIPTION="icon theme for Linux"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r ePapirus Papirus{,-Dark,-Light}
+
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }