summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 00:24:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 00:35:42 +0100
commit93d69e04f98901ce2efaed1945cf75613916ac9e (patch)
tree86f0a3a811470c98524230a56dbdd068b764ebed /xfce-base
parentxfce-base/xfconf: Bump to 4.16.0 (diff)
downloadgentoo-93d69e04f98901ce2efaed1945cf75613916ac9e.tar.gz
gentoo-93d69e04f98901ce2efaed1945cf75613916ac9e.tar.bz2
gentoo-93d69e04f98901ce2efaed1945cf75613916ac9e.zip
xfce-base/libxfce4ui: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.16.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 9952695c545b..b4d36470a2f3 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,3 +1,4 @@
DIST libxfce4ui-4.14.1.tar.bz2 756175 BLAKE2B d487cc0a04b6053ead6670eeb83cafe1c4098818d5ad6a94a81176720d78cfd65160156961cbb526baa1640ae66a5c6958f707b7078c412d81fcd24cc8cf4013 SHA512 f42f41da3a683a0c56c3b1e7ba420c4f50909d2613e681d053b09b50bc0eb7f750f44c892e94b0ee8b9207983a87c0cadbda1ad93d0df74ae351dc8812025407
DIST libxfce4ui-4.15.7.tar.bz2 807676 BLAKE2B 0280d0e35244740d016fc4cd8afebb5a70348226011473117c3b7124abcc597baf8015754bb8aaa2fa3f0560d1a98d68f319c5b5870e1c8f5543c0a9458eb541 SHA512 0fd05bbaa42d3f3a0df552fb7419ebc390e6292f4bae58d4c9d6137421cdd55f17756e51c3adcd5ad6e7c92f277b9485ea1d791ef1295ac3d65d86201fc33a6a
DIST libxfce4ui-4.15.8.tar.bz2 817242 BLAKE2B f0d85fd6e35f65ed416085fbd5da4a1624d8ea9eb90b692463f41e840cea943dbf25a9d057db6101288000fad46468efa4417be87ef24b02f2f73c0a6d11c144 SHA512 a6ea4b6fc1542f6bbc2a2003e1836f1e24ea8c36460460e9e7eddafc7c3c36206fe94a9ccdc17b3b488e857d11a1f1b21ff248349a9820fe9a584bb9dcc1a90f
+DIST libxfce4ui-4.16.0.tar.bz2 837838 BLAKE2B a7e0612bb2a6e47fb9e03c69f1f014740b1ed0f363e198823b328980c106bf5566c880cdeac254291a44ff5a4fc6c8ae95c0396b37e6869e0ec3721897c75d43 SHA512 07ce8399ca860d5414f91b0795ba61eff21b6022a9e8c26de77a6c4e6c45371e10318b626a892b7e2998d95c7e92cf32c2cd48fdefc291bb5521fe8a6cf93aed
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.16.0.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.16.0.ebuild
new file mode 100644
index 000000000000..5ec78d67a32b
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.16.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}