summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/z3/z3-4.5.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-mathematics/z3/z3-4.5.0.ebuild b/sci-mathematics/z3/z3-4.5.0.ebuild
index 30eea151404e..0cd4becd5485 100644
--- a/sci-mathematics/z3/z3-4.5.0.ebuild
+++ b/sci-mathematics/z3/z3-4.5.0.ebuild
@@ -79,8 +79,13 @@ src_configure() {
$(usex python --python "") \
$(usex java --java "")
elog ./configure "$@"
- ./configure "$@" || die
- ${EPYTHON} scripts/mk_make.py || die
+ # LANG=C to force external tools to output ascii text only
+ # otherwise configure crashes as:
+ # File "scripts/mk_make.py", line 21, in <module>
+ # UnicodeEncodeError: 'ascii' codec can't encode characters in position 80-82: ordinal not in range(128)
+ LANG=C ./configure "$@" || die
+ elog ${EPYTHON} scripts/mk_make.py "$@"
+ LANG=C ${EPYTHON} scripts/mk_make.py || die
}
src_compile() {