summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/uemacs-pk/Manifest1
-rw-r--r--app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/uemacs-pk/Manifest b/app-editors/uemacs-pk/Manifest
index 8ad8909e6987..1390414055ff 100644
--- a/app-editors/uemacs-pk/Manifest
+++ b/app-editors/uemacs-pk/Manifest
@@ -1 +1,2 @@
DIST uemacs-4.0.15_p20141208.tar.xz 151500 BLAKE2B 18fed2319b7440583e4e5bb46b8f05a7fe3ec7ffc44c1c8d6311a760472a509a28bc8bbded02f1128d0d663bc78b6a9382173d203bad83a1d09503a992382d33 SHA512 a632c82275ee652412aec7d8f3549d80c5fd5bb1211675828ec4c58365bb7819927ff4e92f6fb7b5b9030b681062773ea19f1af345d4d3ddb652c3d68507bdbb
+DIST uemacs-4.0.15_p20180117.tar.xz 151600 BLAKE2B 76a6a3cd3d0abf720721c7c09687c1964958e6c1c05ad8db07e6e561d6714e436d31659d118af85d069ad77da2606b0ac86005824e2ac56db8040a0ea739aabf SHA512 aadf3f9e8ab3f2c9c7bccf305f7a37e75ac1c92c5c388ce35a10b24cedf886f7d9b0ce8b1196c2f96a0d874bd5af130edb3ecb1ccf571d8e8c00753564e38aa7
diff --git a/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild b/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild
new file mode 100644
index 000000000000..726fa1800847
--- /dev/null
+++ b/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="uEmacs/PK is an enhanced version of MicroEMACS"
+HOMEPAGE="https://git.kernel.org/?p=editors/uemacs/uemacs.git;a=summary
+ ftp://ftp.cs.helsinki.fi/pub/Software/Local/uEmacs-PK"
+# snapshot from git repo
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/uemacs-${PV}.tar.xz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/uemacs"
+PATCHES=("${FILESDIR}"/${PN}-4.0.15_p20110825-gentoo.patch)
+
+src_compile() {
+ emake V=1 \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ dobin em
+ insinto /usr/share/${PN}
+ doins emacs.hlp
+ newins emacs.rc .emacsrc
+ dodoc README readme.39e emacs.ps UTF-8-demo.txt
+}