summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild')
-rw-r--r--app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild b/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild
new file mode 100644
index 000000000000..726fa1800847
--- /dev/null
+++ b/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180117.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="uEmacs/PK is an enhanced version of MicroEMACS"
+HOMEPAGE="https://git.kernel.org/?p=editors/uemacs/uemacs.git;a=summary
+ ftp://ftp.cs.helsinki.fi/pub/Software/Local/uEmacs-PK"
+# snapshot from git repo
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/uemacs-${PV}.tar.xz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/uemacs"
+PATCHES=("${FILESDIR}"/${PN}-4.0.15_p20110825-gentoo.patch)
+
+src_compile() {
+ emake V=1 \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ dobin em
+ insinto /usr/share/${PN}
+ doins emacs.hlp
+ newins emacs.rc .emacsrc
+ dodoc README readme.39e emacs.ps UTF-8-demo.txt
+}