summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/dmenu/dmenu-4.7-r1.ebuild (renamed from x11-misc/dmenu/dmenu-4.7.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11-misc/dmenu/dmenu-4.7.ebuild b/x11-misc/dmenu/dmenu-4.7-r1.ebuild
index 47042fad0e71..05dc375cb2ba 100644
--- a/x11-misc/dmenu/dmenu-4.7.ebuild
+++ b/x11-misc/dmenu/dmenu-4.7-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs
+inherit savedconfig toolchain-funcs
DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
HOMEPAGE="https://tools.suckless.org/dmenu/"
@@ -36,6 +36,8 @@ src_prepare() {
-e 's|${CC} -o|$(CC) $(CFLAGS) -o|g' \
-e '/^ echo/d' \
Makefile || die
+
+ restore_config config.h
}
src_compile() {
@@ -54,4 +56,6 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" PREFIX="/usr" install
+
+ save_config config.h
}