summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild')
-rw-r--r--app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild b/app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild
new file mode 100644
index 000000000000..98aa6724dab5
--- /dev/null
+++ b/app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="Kernel driver for AMD Ryzen's System Management Unit"
+HOMEPAGE="https://gitlab.com/leogx9r/ryzen_smu"
+SRC_URI="https://gitlab.com/leogx9r/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ local modlist=( ryzen_smu )
+ local modargs=( KERNEL_BUILD="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ insinto /usr/lib/modules-load.d
+ doins "${FILESDIR}"/ryzen_smu.conf
+}