summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ryzen_smu')
-rw-r--r--app-admin/ryzen_smu/Manifest2
-rw-r--r--app-admin/ryzen_smu/metadata.xml13
-rw-r--r--app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild28
-rw-r--r--app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205.ebuild47
-rw-r--r--app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild30
5 files changed, 117 insertions, 3 deletions
diff --git a/app-admin/ryzen_smu/Manifest b/app-admin/ryzen_smu/Manifest
index 55487ffbafa3..595450b0211e 100644
--- a/app-admin/ryzen_smu/Manifest
+++ b/app-admin/ryzen_smu/Manifest
@@ -1,2 +1,4 @@
DIST ryzen_smu-0.1.2.tar.gz 169644 BLAKE2B 48445c857d10077b87513d1ccaf6b94d46f6c9179f327de4309d699a17bdd6b41f956e29e324a466451fb2ed68218730c0a02a19b820909cc606eaeea85ed9ab SHA512 7a47b193c7143c3b6bcc2943f9ee895fa1184c9c14953e728cda4f6c8416bef19f0c5fa34344bc47e21101f47816961c4a5f222fd70a7d29401452f90c75ba04
DIST ryzen_smu-0.1.2_p20210627.tar.xz 151900 BLAKE2B c3845755753256aeee4e68d106e2f61c3c2578a31035eebac60d6e484f60a592de1c67574519d48cf251403cc118dd98efd030d4d7eee23f58b8f7b0d2e0ca8c SHA512 65578d8696fe3b8d002895614df72d57700fb1a5b8587fe0671a6863446fad72425400f9f6767abfdc636927132820e63b7f780fd9e88b5ab4b13668be405ed0
+DIST ryzen_smu-0.1.2_p20211205.tar.xz 386260 BLAKE2B eea0466f6abd93a18c670fbbf603be7efb60807865151543341b6a0a9f248eff8a99d8ecda864bebab6e5e2471ff7239681a83ae9b3dded3b1350a7f363ee62c SHA512 93f7eaac4811ac6e3d46abeb012b1ff4e334fc9247a3747ca67489a35ea04dce20806ae2e57f46e930e5238d1d2a966e8d0b83f8bf090a735d0c2d078f3256f3
+DIST ryzen_smu-v0.1.5.tar.bz2 415723 BLAKE2B 0fed89aad85a5080d4c1a6ecdaaef6ffe2b70f0cebbf58392c725f1aa626151e4b5335096bd63cf73ff29d6f5768ce6e0a844dc7030e8c1e4dc5e04990521651 SHA512 5793beae8204a16800ed876da2a07d2f477a21cef706fed6076e1dcc6e74118b7c45a330e264302d644fdb49f7c44e4fca53dc67e43b2f2a62b3b1ea4ad00d8f
diff --git a/app-admin/ryzen_smu/metadata.xml b/app-admin/ryzen_smu/metadata.xml
index 8ac26ba5990d..724cb7041d8f 100644
--- a/app-admin/ryzen_smu/metadata.xml
+++ b/app-admin/ryzen_smu/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>slashbeast@gentoo.org</email>
- <name>Piotr Karbowski</name>
+ <maintainer type="person" proxied="yes">
+ <email>negril.nx+gentoo@gmail.com</email>
+ <name>Paul Zander</name>
</maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">leogx9r/ryzen_smu</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild
new file mode 100644
index 000000000000..e755b5a98fce
--- /dev/null
+++ b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="Kernel driver for AMD Ryzen's System Management Unit"
+HOMEPAGE="https://github.com/leogx9r/ryzen_smu"
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_compile() {
+ local modlist=( ryzen_smu )
+ local modargs=( KERNEL_BUILD="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ insinto /usr/lib/modules-load.d
+ doins "${FILESDIR}"/ryzen_smu.conf
+}
diff --git a/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205.ebuild b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205.ebuild
new file mode 100644
index 000000000000..96e15892d055
--- /dev/null
+++ b/app-admin/ryzen_smu/ryzen_smu-0.1.2_p20211205.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod linux-info toolchain-funcs
+
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="Kernel driver for AMD Ryzen's System Management Unit"
+HOMEPAGE="https://github.com/leogx9r/ryzen_smu"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+MODULE_NAMES="ryzen_smu(misc)"
+
+pkg_setup() {
+ linux_config_exists
+
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="modules"
+ BUILD_PARAMS="KERNEL_BUILD=${KERNEL_DIR}"
+ if linux_chkconfig_present CC_IS_CLANG; then
+ BUILD_PARAMS+=" CC=${CHOST}-clang"
+ if linux_chkconfig_present LD_IS_LLD; then
+ BUILD_PARAMS+=' LD=ld.lld'
+ if linux_chkconfig_present LTO_CLANG_THIN; then
+ # kernel enables cache by default leading to sandbox violations
+ BUILD_PARAMS+=' ldflags-y=--thinlto-cache-dir= LDFLAGS_MODULE=--thinlto-cache-dir='
+ fi
+ fi
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ newins "${FILESDIR}"/ryzen_smu.conf ryzen_smu.conf
+
+}
diff --git a/app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild b/app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild
new file mode 100644
index 000000000000..98aa6724dab5
--- /dev/null
+++ b/app-admin/ryzen_smu/ryzen_smu-0.1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="Kernel driver for AMD Ryzen's System Management Unit"
+HOMEPAGE="https://gitlab.com/leogx9r/ryzen_smu"
+SRC_URI="https://gitlab.com/leogx9r/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ local modlist=( ryzen_smu )
+ local modargs=( KERNEL_BUILD="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ insinto /usr/lib/modules-load.d
+ doins "${FILESDIR}"/ryzen_smu.conf
+}