summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/ioping')
-rw-r--r--app-benchmarks/ioping/Manifest2
-rw-r--r--app-benchmarks/ioping/files/ioping-0.6-makefile.patch26
-rw-r--r--app-benchmarks/ioping/ioping-0.8.ebuild35
-rw-r--r--app-benchmarks/ioping/ioping-0.9.ebuild37
-rw-r--r--app-benchmarks/ioping/metadata.xml11
5 files changed, 111 insertions, 0 deletions
diff --git a/app-benchmarks/ioping/Manifest b/app-benchmarks/ioping/Manifest
new file mode 100644
index 000000000000..c9154a7686f3
--- /dev/null
+++ b/app-benchmarks/ioping/Manifest
@@ -0,0 +1,2 @@
+DIST ioping-0.8.tar.gz 10590 SHA256 e23fdbd7298e26b63986137d6007e5a72d495da7265b9edea4c12f1b0c55fe48 SHA512 f15716eb60d40db2509c51b7448dbe0d2443888ccf83f708618d72bc41c8ff8d5da2a342fd68131536c7bcb316d7f68461940797366b7c2f277cfb9b2c3b87a2 WHIRLPOOL 07e312a660a7fffbbe9c85b5b4109e130e6f41ec6486313c7ee8bd9ad730191589108db4de537529e3d8448be434be0694ea94ee1ea87a7796045b83329714f1
+DIST ioping-0.9.tar.gz 23695 SHA256 951e430875987c8cfe0ed85a0bcfe1081788121a34102eb6f7c91330c63a775d SHA512 609e19c31a16a5961be0e468255f2853311162ad988d07404a8198042bec1e20cab37e192ad148536a0772efe8034a94d594671ec6fde7d37badee859796de1c WHIRLPOOL e9dec9d139b1b85f379c65d99676bfbbda30b78bf8cfa9a2a238db0e9eb43f6a2cb119ba64e35f9a81dc530b29015062b6e9585661f97449a22c35dc930dbcdd
diff --git a/app-benchmarks/ioping/files/ioping-0.6-makefile.patch b/app-benchmarks/ioping/files/ioping-0.6-makefile.patch
new file mode 100644
index 000000000000..b5836696e9f4
--- /dev/null
+++ b/app-benchmarks/ioping/files/ioping-0.6-makefile.patch
@@ -0,0 +1,26 @@
+ Makefile | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index b3d741e..79022e9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+-CFLAGS+=-std=c99 -g -Wall -Wextra -pedantic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+-LDFLAGS=-lm
+-PREFIX=/usr/local
++CFLAGS+=-std=c99 -Wall -Wextra -pedantic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++LIBS=-lm
++PREFIX?=/usr/local
+ BINDIR=$(PREFIX)/bin
+ MAN1DIR=$(PREFIX)/share/man/man1
+
+@@ -30,7 +30,7 @@ install: $(BINS) $(MANS)
+ $(CC) $(CFLAGS) -DVERSION=\"${VERSION}\" -c -o $@ $^
+
+ ioping: $(OBJS)
+- $(CC) -o $@ $^ $(CFLAGS) $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ dist: $(DISTDIR).tar.gz
+
diff --git a/app-benchmarks/ioping/ioping-0.8.ebuild b/app-benchmarks/ioping/ioping-0.8.ebuild
new file mode 100644
index 000000000000..ae96fcfe749d
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="http://code.google.com/p/ioping/"
+SRC_URI="http://ioping.googlecode.com/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+src_prepare() {
+ sed \
+ -e 's: -g : :g' \
+ -e 's: $(LDFLAGS) : :g' \
+ -e 's: -o : $(LDFLAGS) -o :g' \
+ -e 's:-s -m:-m:g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
diff --git a/app-benchmarks/ioping/ioping-0.9.ebuild b/app-benchmarks/ioping/ioping-0.9.ebuild
new file mode 100644
index 000000000000..b6079a33adee
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="https://github.com/koct9i/ioping"
+SRC_URI="https://github.com/koct9i/ioping/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+src_prepare() {
+ sed \
+ -e 's: -g : :g' \
+ -e 's: $(LDFLAGS) : :g' \
+ -e 's: -o : $(LDFLAGS) -o :g' \
+ -e 's:-s -m:-m:g' \
+ -e 's:LICENSE::g' \
+ -e 's:-O2.*::g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
diff --git a/app-benchmarks/ioping/metadata.xml b/app-benchmarks/ioping/metadata.xml
new file mode 100644
index 000000000000..9d1e924aa17b
--- /dev/null
+++ b/app-benchmarks/ioping/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">ioping</remote-id>
+ <remote-id type="github">koct9i/ioping</remote-id>
+ </upstream>
+</pkgmetadata>