summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/xca/files/xca-2.4.0-man-page.patch')
-rw-r--r--app-crypt/xca/files/xca-2.4.0-man-page.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-crypt/xca/files/xca-2.4.0-man-page.patch b/app-crypt/xca/files/xca-2.4.0-man-page.patch
new file mode 100644
index 000000000000..a5b52176418d
--- /dev/null
+++ b/app-crypt/xca/files/xca-2.4.0-man-page.patch
@@ -0,0 +1,24 @@
+--- a/doc/CMakeLists.txt 2023-09-09 11:10:22.671031619 +0200
++++ b/doc/CMakeLists.txt 2023-09-09 11:17:15.398798825 +0200
+@@ -138,7 +138,7 @@
+ if (NOT WIN32)
+ add_custom_command(
+- OUTPUT "${D}/xca.1.gz"
++ OUTPUT "${D}/xca.1"
+- COMMAND cat "${S}/xca.1.head" "${D}/xca.1.options" "${S}/xca.1.tail" | gzip -n9 > "${D}/xca.1.gz"
++ COMMAND cat "${S}/xca.1.head" "${D}/xca.1.options" "${S}/xca.1.tail" | cat > "${D}/xca.1"
+ DEPENDS "${S}/xca.1.head" "${S}/xca.1.tail"
+ "${D}/xca.1.options"
+ COMMENT "Compiling man page"
+@@ -148,9 +148,9 @@
+ COMMAND xcadoc man "${D}/xca.1.options"
+ COMMENT "Generate 'man' commandline documentation"
+ )
+- add_custom_target(manpage ALL DEPENDS ${D}/xca.1.gz)
++ add_custom_target(manpage ALL DEPENDS ${D}/xca.1)
+ if (NOT APPLE)
+- install(FILES "${D}/xca.1.gz"
++ install(FILES "${D}/xca.1"
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
+ )
+ endif()