summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/xca/files')
-rw-r--r--app-crypt/xca/files/xca-2.3.0-bug-733000.patch28
-rw-r--r--app-crypt/xca/files/xca-2.4.0-bug-733000.patch29
-rw-r--r--app-crypt/xca/files/xca-2.4.0-man-page.patch24
3 files changed, 24 insertions, 57 deletions
diff --git a/app-crypt/xca/files/xca-2.3.0-bug-733000.patch b/app-crypt/xca/files/xca-2.3.0-bug-733000.patch
deleted file mode 100644
index 044575475c89..000000000000
--- a/app-crypt/xca/files/xca-2.3.0-bug-733000.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/doc/Makefile b/doc/Makefile
-index d481c5a..dc5b49a 100644
---- a/doc/Makefile
-+++ b/doc/Makefile
-@@ -5,13 +5,9 @@ endif
-
- DELFILES=xca*.html xca.1.gz changelog.html database_schema.html
-
--doc: xca.1.gz xca.html changelog.html database_schema.html
-+doc: xca.1 xca.html changelog.html database_schema.html
- include $(TOPDIR)/Rules.mak
-
--%.1.gz: %.1
-- @$(PRINT) " MAN [$(BASENAME)] $@"
-- gzip -9 <$^ >$@
--
- xca.html: xca.sgml
- rm -f xca*.html
- echo 'The documentation for XCA can be viewed online at: <a href="http://hohnstaedt.de/documentation">http://hohnstaedt.de/documentation</a>.' > $@
-@@ -23,7 +19,7 @@ install: $(doc)
- $(ENABLE_DOC)install -m 755 -d $(DESTDIR)$(htmldir)
- $(ENABLE_DOC)install -m 644 xca*.html $(DESTDIR)$(htmldir)
- install -m 755 -d $(DESTDIR)$(mandir)/man1
-- install -m 644 *.1.gz $(DESTDIR)/$(mandir)/man1
-+ install -m 644 *.1 $(DESTDIR)/$(mandir)/man1
-
- app: xca.html
- mkdir -p $(APPDIR)/Resources
diff --git a/app-crypt/xca/files/xca-2.4.0-bug-733000.patch b/app-crypt/xca/files/xca-2.4.0-bug-733000.patch
deleted file mode 100644
index 0863c906957e..000000000000
--- a/app-crypt/xca/files/xca-2.4.0-bug-733000.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/doc/Makefile 2021-05-07 22:40:29.000000000 +0200
-+++ b/doc/Makefile 2021-08-11 07:29:33.794844656 +0200
-@@ -12,16 +12,12 @@
-
- SPHINX_FILES=$(patsubst %,sphinx/%.rst,$(RST_FILES))
-
--.build-stamp doc: xca.1.gz html/index.html qthelp/xca.qhc
-+.build-stamp doc: xca.1 html/index.html qthelp/xca.qhc
- qthelpfiles=qthelp/*.html qthelp/xca.qhc qthelp/xca.qch
- .install-stamp: doc
-
- include $(TOPDIR)/Rules.mak
-
--%.1.gz: %.1
-- @$(PRINT) " MAN [$(BASENAME)] $@"
-- gzip -9 <$^ >$@
--
- xca.1: xca.1.head xca.1.options xca.1.tail
- cat $^ > $@
-
-@@ -43,7 +39,7 @@
- $(ENABLE_DOC)install -m 755 -d $(DESTDIR)$(htmldir)
- $(ENABLE_DOC)install -m 644 $(qthelpfiles) $(DESTDIR)$(htmldir)
- install -m 755 -d $(DESTDIR)$(mandir)/man1
-- install -m 644 *.1.gz $(DESTDIR)/$(mandir)/man1
-+ install -m 644 *.1 $(DESTDIR)/$(mandir)/man1
-
- app: $(doc)
- mkdir -p $(APPDIR)/Resources
diff --git a/app-crypt/xca/files/xca-2.4.0-man-page.patch b/app-crypt/xca/files/xca-2.4.0-man-page.patch
new file mode 100644
index 000000000000..a5b52176418d
--- /dev/null
+++ b/app-crypt/xca/files/xca-2.4.0-man-page.patch
@@ -0,0 +1,24 @@
+--- a/doc/CMakeLists.txt 2023-09-09 11:10:22.671031619 +0200
++++ b/doc/CMakeLists.txt 2023-09-09 11:17:15.398798825 +0200
+@@ -138,7 +138,7 @@
+ if (NOT WIN32)
+ add_custom_command(
+- OUTPUT "${D}/xca.1.gz"
++ OUTPUT "${D}/xca.1"
+- COMMAND cat "${S}/xca.1.head" "${D}/xca.1.options" "${S}/xca.1.tail" | gzip -n9 > "${D}/xca.1.gz"
++ COMMAND cat "${S}/xca.1.head" "${D}/xca.1.options" "${S}/xca.1.tail" | cat > "${D}/xca.1"
+ DEPENDS "${S}/xca.1.head" "${S}/xca.1.tail"
+ "${D}/xca.1.options"
+ COMMENT "Compiling man page"
+@@ -148,9 +148,9 @@
+ COMMAND xcadoc man "${D}/xca.1.options"
+ COMMENT "Generate 'man' commandline documentation"
+ )
+- add_custom_target(manpage ALL DEPENDS ${D}/xca.1.gz)
++ add_custom_target(manpage ALL DEPENDS ${D}/xca.1)
+ if (NOT APPLE)
+- install(FILES "${D}/xca.1.gz"
++ install(FILES "${D}/xca.1"
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
+ )
+ endif()