summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-18.59-r11.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-editors/emacs/emacs-18.59-r11.ebuild b/app-editors/emacs/emacs-18.59-r11.ebuild
index c7a9e9dfa5d9..8b9d3d2c04e9 100644
--- a/app-editors/emacs/emacs-18.59-r11.ebuild
+++ b/app-editors/emacs/emacs-18.59-r11.ebuild
@@ -60,11 +60,13 @@ src_configure() {
src/s-linux.h || die
# -O3 and -finline-functions cause segmentation faults at run time.
- filter-flags -finline-functions
- replace-flags -O[3-9] -O2
+ # -Wno-implicit will quieten GCC 5; feel free to submit a patch
+ # adding all those missing prototypes.
strip-flags
- # Quieten GCC 5. Feel free to submit a patch adding all those prototypes.
+ filter-flags -finline-functions -fpie
append-flags -Wno-implicit
+ append-ldflags $(test-flags -no-pie) #639562
+ replace-flags -O[3-9] -O2
}
src_compile() {