summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-12-11 00:52:34 +0100
committerUlrich Müller <ulm@gentoo.org>2017-12-11 00:56:50 +0100
commit378170ef0a5bcc0c7511badf188575b7e6055ccc (patch)
tree26c8a655f76b9a968019387b342402182fcb3f34 /app-editors
parentapp-editors/emacs: Fix build failure with 17.0 profiles. (diff)
downloadgentoo-378170ef0a5bcc0c7511badf188575b7e6055ccc.tar.gz
gentoo-378170ef0a5bcc0c7511badf188575b7e6055ccc.tar.bz2
gentoo-378170ef0a5bcc0c7511badf188575b7e6055ccc.zip
app-editors/emacs: Fix Emacs 18 build failure with 17.0 profiles.
Adding -no-pie to LDFLAGS also does the trick for emacs-18.59. Rearrange toolchain flag manipulation a bit. Closes: https://bugs.gentoo.org/639562 Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-18.59-r11.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-editors/emacs/emacs-18.59-r11.ebuild b/app-editors/emacs/emacs-18.59-r11.ebuild
index c7a9e9dfa5d9..8b9d3d2c04e9 100644
--- a/app-editors/emacs/emacs-18.59-r11.ebuild
+++ b/app-editors/emacs/emacs-18.59-r11.ebuild
@@ -60,11 +60,13 @@ src_configure() {
src/s-linux.h || die
# -O3 and -finline-functions cause segmentation faults at run time.
- filter-flags -finline-functions
- replace-flags -O[3-9] -O2
+ # -Wno-implicit will quieten GCC 5; feel free to submit a patch
+ # adding all those missing prototypes.
strip-flags
- # Quieten GCC 5. Feel free to submit a patch adding all those prototypes.
+ filter-flags -finline-functions -fpie
append-flags -Wno-implicit
+ append-ldflags $(test-flags -no-pie) #639562
+ replace-flags -O[3-9] -O2
}
src_compile() {