summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/js2-mode/js2-mode-20230408.ebuild')
-rw-r--r--app-emacs/js2-mode/js2-mode-20230408.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-emacs/js2-mode/js2-mode-20230408.ebuild b/app-emacs/js2-mode/js2-mode-20230408.ebuild
new file mode 100644
index 000000000000..0f171722ca2a
--- /dev/null
+++ b/app-emacs/js2-mode/js2-mode-20230408.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Improved JavaScript editing mode for GNU Emacs"
+HOMEPAGE="https://github.com/mooz/js2-mode/"
+SRC_URI="https://github.com/mooz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( NEWS.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test
+}