summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/js2-mode')
-rw-r--r--app-emacs/js2-mode/Manifest2
-rw-r--r--app-emacs/js2-mode/files/50js2-mode-gentoo.el12
-rw-r--r--app-emacs/js2-mode/js2-mode-20230408.ebuild21
-rw-r--r--app-emacs/js2-mode/js2-mode-20231224.ebuild30
-rw-r--r--app-emacs/js2-mode/metadata.xml27
5 files changed, 92 insertions, 0 deletions
diff --git a/app-emacs/js2-mode/Manifest b/app-emacs/js2-mode/Manifest
new file mode 100644
index 000000000000..14d022768ac1
--- /dev/null
+++ b/app-emacs/js2-mode/Manifest
@@ -0,0 +1,2 @@
+DIST js2-mode-20230408.tar.gz 166178 BLAKE2B 6b567da9cd29c7aed40122a6b18af0c87e3197d00d1def663d700e260e8c83c83d07fb27e19e85a7fe0fa6487177a5191868d9caadf714d216e2ac01f9b95ddc SHA512 c3df3e88a627c7fbb3d7747760a4b27fd0da1a922a8e75f346ebdd00f5e682222c5a2cb636f7d19fc0f5c920892c77b8ed73c13ce6987d103366beb9e2b0b4b5
+DIST js2-mode-20231224.tar.gz 166532 BLAKE2B f809132897fa1f87f5d7a6cd798d77eb3dd0b6ab7cddba2a89702774e0114ab7f1061ce3bdd5299340088924ebf61370e1b6432ea782176f4a875a41be973f08 SHA512 df294bea7d01f185e12435364fb97954fe772c76887321cb7b41829c6b40b706dbd1800569dd795e3d93de800d38bfa465e3bb22a932cfc3a0400760aeac0c2d
diff --git a/app-emacs/js2-mode/files/50js2-mode-gentoo.el b/app-emacs/js2-mode/files/50js2-mode-gentoo.el
new file mode 100644
index 000000000000..12daf0e43291
--- /dev/null
+++ b/app-emacs/js2-mode/files/50js2-mode-gentoo.el
@@ -0,0 +1,12 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'js2-imenu-extras-setup "js2-imenu-extras")
+(autoload 'js2-imenu-extras-mode "js2-imenu-extras"
+ "Toggle Imenu support for frameworks and structural patterns." t)
+(autoload 'js2-highlight-unused-variables-mode "js2-mode"
+ "Toggle highlight of unused variables." t)
+(autoload 'js2-minor-mode "js2-mode"
+ "Minor mode for running js2 as a background linter." t)
+(autoload 'js2-mode "js2-mode"
+ "Major mode for editing JavaScript code." t)
+(autoload 'js2-jsx-mode "js2-mode"
+ "Major mode for editing JSX code in Emacs 26 and earlier." t)
diff --git a/app-emacs/js2-mode/js2-mode-20230408.ebuild b/app-emacs/js2-mode/js2-mode-20230408.ebuild
new file mode 100644
index 000000000000..0f171722ca2a
--- /dev/null
+++ b/app-emacs/js2-mode/js2-mode-20230408.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Improved JavaScript editing mode for GNU Emacs"
+HOMEPAGE="https://github.com/mooz/js2-mode/"
+SRC_URI="https://github.com/mooz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( NEWS.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test
+}
diff --git a/app-emacs/js2-mode/js2-mode-20231224.ebuild b/app-emacs/js2-mode/js2-mode-20231224.ebuild
new file mode 100644
index 000000000000..ce8782cda510
--- /dev/null
+++ b/app-emacs/js2-mode/js2-mode-20231224.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Improved JavaScript editing mode for GNU Emacs"
+HOMEPAGE="https://github.com/mooz/js2-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mooz/${PN}.git"
+else
+ SRC_URI="https://github.com/mooz/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( NEWS.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test
+}
diff --git a/app-emacs/js2-mode/metadata.xml b/app-emacs/js2-mode/metadata.xml
new file mode 100644
index 000000000000..2983ab1f4170
--- /dev/null
+++ b/app-emacs/js2-mode/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This JavaScript editing mode supports: 1. strict recognition of the
+ Ecma-262 language standard 2. support for most Rhino and SpiderMonkey
+ extensions from 1.5 and up 3. parsing support for ECMAScript for XML (E4X,
+ ECMA-357) 4. accurate syntax highlighting using a recursive-descent parser
+ 5. on-the-fly reporting of syntax errors and strict-mode warnings 6.
+ undeclared-variable warnings using a configurable externs framework 7.
+ "bouncing" line indentation to choose among alternate indentation points 8.
+ smart line-wrapping within comments and strings 9. code folding: 9.1. show
+ some or all function bodies as {...} 9.2. show some or all block comments
+ as /*...*/ 12. context-sensitive menu bar and popup menus 13. code browsing
+ using the `imenu' package 14. many customization options
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/mooz/js2-mode/issues/</bugs-to>
+ <remote-id type="github">mooz/js2-mode</remote-id>
+ </upstream>
+</pkgmetadata>