summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild')
-rw-r--r--app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild b/app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild
new file mode 100644
index 000000000000..4ca0bf29270d
--- /dev/null
+++ b/app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Cloud image storage services client (like Flickr or Picasa)"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +deathnote +rappor +spegnersi +vangog"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ deathnote? ( dev-qt/qtxmlpatterns:4 )
+ spegnersi? ( dev-libs/kqoauth )
+ vangog? ( dev-libs/qjson )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ local mycmakeargs=(
+ $(cmake-utils_use_enable deathnote BLASQ_DEATHNOTE)
+ $(cmake-utils_use_enable rappor BLASQ_RAPPOR)
+ $(cmake-utils_use_enable spegnersi BLASQ_SPEGNERSI)
+ $(cmake-utils_use_enable vangog BLASQ_VANGOG)
+ )
+
+ cmake-utils_src_configure
+}