summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-blasq')
-rw-r--r--app-leechcraft/lc-blasq/Manifest3
-rw-r--r--app-leechcraft/lc-blasq/lc-blasq-0.6.60.ebuild31
-rw-r--r--app-leechcraft/lc-blasq/lc-blasq-0.6.65.ebuild31
-rw-r--r--app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild31
-rw-r--r--app-leechcraft/lc-blasq/lc-blasq-9999.ebuild31
-rw-r--r--app-leechcraft/lc-blasq/metadata.xml11
6 files changed, 138 insertions, 0 deletions
diff --git a/app-leechcraft/lc-blasq/Manifest b/app-leechcraft/lc-blasq/Manifest
new file mode 100644
index 000000000000..1911f838b33a
--- /dev/null
+++ b/app-leechcraft/lc-blasq/Manifest
@@ -0,0 +1,3 @@
+DIST leechcraft-0.6.60.tar.xz 5089252 SHA256 669c2325235c3c49dfc9a30d38c1ad08c0a6abf1ebbf2c8d33eca27e976e1b6d SHA512 0bac75f96bfc43c692e8b61ba5e9b6b82d535a78bd310966c36579666feb8b87217a9d74cfe792fa32b57b9b04e158239acbf2422014735d2316cbda2d8b39ec WHIRLPOOL f3056faab0006830afbcf5f3448094e530c908d432cebec731f305f34347e514db55416a911674c28445a3cd4e542136fd053ee5e444b3cf93e086dc9e88428c
+DIST leechcraft-0.6.65.tar.xz 5067580 SHA256 b821fb8716b3ba04862bbb358a738609ead84cd9c86b569fe31c712b48c2a7fd SHA512 94e3cfa42bea572cb2feeaf4c7153c8d7e08e0597d447db5033b72222cea67370e8948d0dd0e2b89585583a88b4ee3df7b32d72dcd624d383e79b9472ceffe30 WHIRLPOOL bc589f46c89351328e25e6e32febdcba8ead639a8d1daf18df7352372d66fb8f8e7e5bbef02d49b6a00a7f5ffa15d66699b79cc73f64ea1bf8b59949fcd81b8a
+DIST leechcraft-0.6.70.tar.xz 5204940 SHA256 3e7f51da0b7eec6df11471ada409d752754f3badc388b8f0adab3f056fabcd45 SHA512 fedf0467e39bd512c937b25f5da62af2be7908831169e1d82d10af43b7c164be2658138663578d7658c3692d5269dd3df9e391744561443f49771edd063ba408 WHIRLPOOL a0aef0bdc11d4b3a3680a055671208db0528bb4744930a0fecab6d1fbf99cc87f4fd8483e98e93357a4c0dda1f3edc1a20a9a725b28ea9003c564469531a2d37
diff --git a/app-leechcraft/lc-blasq/lc-blasq-0.6.60.ebuild b/app-leechcraft/lc-blasq/lc-blasq-0.6.60.ebuild
new file mode 100644
index 000000000000..b2fe82e19ecb
--- /dev/null
+++ b/app-leechcraft/lc-blasq/lc-blasq-0.6.60.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Cloud image storage services client (like Flickr or Picasa)"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +deathnote +rappor +spegnersi +vangog"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ deathnote? ( dev-qt/qtxmlpatterns:4 )
+ spegnersi? ( dev-libs/kqoauth )
+ vangog? ( dev-libs/qjson )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ local mycmakeargs=(
+ $(cmake-utils_use_enable deathnote BLASQ_DEATHNOTE)
+ $(cmake-utils_use_enable rappor BLASQ_RAPPOR)
+ $(cmake-utils_use_enable spegnersi BLASQ_SPEGNERSI)
+ $(cmake-utils_use_enable vangog BLASQ_VANGOG)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-blasq/lc-blasq-0.6.65.ebuild b/app-leechcraft/lc-blasq/lc-blasq-0.6.65.ebuild
new file mode 100644
index 000000000000..4ca0bf29270d
--- /dev/null
+++ b/app-leechcraft/lc-blasq/lc-blasq-0.6.65.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Cloud image storage services client (like Flickr or Picasa)"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +deathnote +rappor +spegnersi +vangog"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ deathnote? ( dev-qt/qtxmlpatterns:4 )
+ spegnersi? ( dev-libs/kqoauth )
+ vangog? ( dev-libs/qjson )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ local mycmakeargs=(
+ $(cmake-utils_use_enable deathnote BLASQ_DEATHNOTE)
+ $(cmake-utils_use_enable rappor BLASQ_RAPPOR)
+ $(cmake-utils_use_enable spegnersi BLASQ_SPEGNERSI)
+ $(cmake-utils_use_enable vangog BLASQ_VANGOG)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild b/app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild
new file mode 100644
index 000000000000..4ca0bf29270d
--- /dev/null
+++ b/app-leechcraft/lc-blasq/lc-blasq-0.6.70.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Cloud image storage services client (like Flickr or Picasa)"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +deathnote +rappor +spegnersi +vangog"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ deathnote? ( dev-qt/qtxmlpatterns:4 )
+ spegnersi? ( dev-libs/kqoauth )
+ vangog? ( dev-libs/qjson )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ local mycmakeargs=(
+ $(cmake-utils_use_enable deathnote BLASQ_DEATHNOTE)
+ $(cmake-utils_use_enable rappor BLASQ_RAPPOR)
+ $(cmake-utils_use_enable spegnersi BLASQ_SPEGNERSI)
+ $(cmake-utils_use_enable vangog BLASQ_VANGOG)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-blasq/lc-blasq-9999.ebuild b/app-leechcraft/lc-blasq/lc-blasq-9999.ebuild
new file mode 100644
index 000000000000..7453543ccab0
--- /dev/null
+++ b/app-leechcraft/lc-blasq/lc-blasq-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Cloud image storage services client (like Flickr or Picasa)"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +deathnote +rappor +spegnersi +vangog"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ deathnote? ( dev-qt/qtxmlpatterns:4 )
+ spegnersi? ( dev-libs/kqoauth )
+ vangog? ( dev-libs/qjson )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ local mycmakeargs=(
+ $(cmake-utils_use_enable deathnote BLASQ_DEATHNOTE)
+ $(cmake-utils_use_enable rappor BLASQ_RAPPOR)
+ $(cmake-utils_use_enable spegnersi BLASQ_SPEGNERSI)
+ $(cmake-utils_use_enable vangog BLASQ_VANGOG)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-blasq/metadata.xml b/app-leechcraft/lc-blasq/metadata.xml
new file mode 100644
index 000000000000..8043a570e35c
--- /dev/null
+++ b/app-leechcraft/lc-blasq/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>leechcraft</herd>
+<use>
+ <flag name="deathnote">Support LiveJournal FotoBilder service</flag>
+ <flag name="rappor">Support VKontakte service</flag>
+ <flag name="spegnersi">Support Flickr service</flag>
+ <flag name="vangog">Support Picasa service</flag>
+</use>
+</pkgmetadata> \ No newline at end of file