summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cstream/cstream-3.2.1-r1.ebuild')
-rw-r--r--app-misc/cstream/cstream-3.2.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/cstream/cstream-3.2.1-r1.ebuild b/app-misc/cstream/cstream-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..3b9594ce01ed
--- /dev/null
+++ b/app-misc/cstream/cstream-3.2.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="General-purpose stream-handling tool like UNIX dd"
+HOMEPAGE="http://www.cons.org/cracauer/cstream.html"
+SRC_URI="http://www.cons.org/cracauer/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.1-Fix-implicit-function-declaration.patch
+)
+
+src_prepare() {
+ default
+
+ rm auxdir/missing || die "Failed to remove auxdir/missing"
+
+ eautoreconf
+}