summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cstream')
-rw-r--r--app-misc/cstream/Manifest2
-rw-r--r--app-misc/cstream/cstream-3.2.1-r1.ebuild (renamed from app-misc/cstream/cstream-3.1.1-r1.ebuild)14
-rw-r--r--app-misc/cstream/files/cstream-3.2.1-Fix-implicit-function-declaration.patch25
-rw-r--r--app-misc/cstream/metadata.xml2
4 files changed, 37 insertions, 6 deletions
diff --git a/app-misc/cstream/Manifest b/app-misc/cstream/Manifest
index 47c4b98b7b6c..262961147b29 100644
--- a/app-misc/cstream/Manifest
+++ b/app-misc/cstream/Manifest
@@ -1 +1 @@
-DIST cstream-3.1.1.tar.gz 96609 BLAKE2B 360183c215e4aaf536d6455393b8e5a27fcfb15dc581205e53c0a160c97d028165cd9c24feea13f9a4ed11de1710ffbd1d548cadaa7fdef912eb1ee932a49ee6 SHA512 8d6364da622711f6888fd221b2f36f5da23d2a562d5a797d58d7ef361415481de8ab9ae55ae856d47c2d0141d570e22a61ab0ce9954c043877196df168f2f43a
+DIST cstream-3.2.1.tar.gz 110388 BLAKE2B 4537f2affd696620f53cfdb08d8f85ba01bdc1b5db8b3d8fa3e373a1ece96f2dc1e88efed20f1278ffde87cd1456b466d87c2c2c05480abdf79af84ca7d629f7 SHA512 f40819f07e27887528d9ff1abe6183e6e97fcefc60eb0b289f20449cdef73567b2cb5f40c52bf66dd3f4c8f869bdfdcbe0faa983659e6f8f427129f75ee1ee70
diff --git a/app-misc/cstream/cstream-3.1.1-r1.ebuild b/app-misc/cstream/cstream-3.2.1-r1.ebuild
index dc7409c52f67..3b9594ce01ed 100644
--- a/app-misc/cstream/cstream-3.1.1-r1.ebuild
+++ b/app-misc/cstream/cstream-3.2.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
-DESCRIPTION="general-purpose stream-handling tool like UNIX dd"
+DESCRIPTION="General-purpose stream-handling tool like UNIX dd"
HOMEPAGE="http://www.cons.org/cracauer/cstream.html"
SRC_URI="http://www.cons.org/cracauer/download/${P}.tar.gz"
@@ -13,8 +13,14 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.1-Fix-implicit-function-declaration.patch
+)
+
src_prepare() {
default
- rm auxdir/missing || die 'failed to remove auxdir/missing'
+
+ rm auxdir/missing || die "Failed to remove auxdir/missing"
+
eautoreconf
}
diff --git a/app-misc/cstream/files/cstream-3.2.1-Fix-implicit-function-declaration.patch b/app-misc/cstream/files/cstream-3.2.1-Fix-implicit-function-declaration.patch
new file mode 100644
index 000000000000..0e158afdd39a
--- /dev/null
+++ b/app-misc/cstream/files/cstream-3.2.1-Fix-implicit-function-declaration.patch
@@ -0,0 +1,25 @@
+From aba21403014d3a0c4886b930ce3e7c07e2df5169 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 25 Oct 2022 13:34:28 +0100
+Subject: [PATCH] Fix implicit function declaration
+
+Bug: https://bugs.gentoo.org/871225
+--- a/cstream.c
++++ b/cstream.c
+@@ -92,6 +92,8 @@
+
+ #ifndef NOSOUND
+
++#include <sys/ioctl.h>
++
+ #ifdef HAVE_MACHINE_SOUNDCARD_H
+ #include <machine/soundcard.h>
+ #define WANT_SOUND 1
+@@ -103,7 +105,6 @@
+ #ifdef HAVE_LINUX_SOUNDCARD_H
+ #include <linux/soundcard.h>
+ #define WANT_SOUND 1
+-#include <sys/ioctl.h>
+ #endif /* linux/soundcard.h */
+ #endif /* either soundcard.h */
+ #endif /* either soundcard.h */
diff --git a/app-misc/cstream/metadata.xml b/app-misc/cstream/metadata.xml
index ecf62c4184c9..9695af158ca7 100644
--- a/app-misc/cstream/metadata.xml
+++ b/app-misc/cstream/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<longdescription lang="en">