summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fdupes/fdupes-9999.ebuild')
-rw-r--r--app-misc/fdupes/fdupes-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-misc/fdupes/fdupes-9999.ebuild b/app-misc/fdupes/fdupes-9999.ebuild
index 9fc8d0597860..3578fdc09788 100644
--- a/app-misc/fdupes/fdupes-9999.ebuild
+++ b/app-misc/fdupes/fdupes-9999.ebuild
@@ -1,26 +1,27 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Identify/delete duplicate files residing within specified directories"
HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
-if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
+ inherit autotools git-r3
else
SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
+
LICENSE="MIT"
SLOT="0"
IUSE="+ncurses"
RDEPEND="
dev-libs/libpcre2[pcre32]
- ncurses? ( sys-libs/ncurses:0= )
+ ncurses? ( sys-libs/ncurses:= )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -29,7 +30,8 @@ DOCS=( CHANGES CONTRIBUTORS README )
src_prepare() {
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
@@ -37,5 +39,5 @@ src_configure() {
}
src_compile() {
- emake CC=$(tc-getCC)
+ emake CC="$(tc-getCC)"
}