summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fdupes')
-rw-r--r--app-misc/fdupes/Manifest3
-rw-r--r--app-misc/fdupes/fdupes-2.1.2.ebuild32
-rw-r--r--app-misc/fdupes/fdupes-2.2.1.ebuild43
-rw-r--r--app-misc/fdupes/fdupes-2.3.0.ebuild44
-rw-r--r--app-misc/fdupes/fdupes-9999.ebuild18
-rw-r--r--app-misc/fdupes/metadata.xml2
6 files changed, 100 insertions, 42 deletions
diff --git a/app-misc/fdupes/Manifest b/app-misc/fdupes/Manifest
index 0288ee4dd113..115b8413452a 100644
--- a/app-misc/fdupes/Manifest
+++ b/app-misc/fdupes/Manifest
@@ -1 +1,2 @@
-DIST fdupes-2.1.2.tar.gz 142266 BLAKE2B caf949b87baf0fecc87fef58f512d0a99e1219b57bc167992b0e40841ce67e5ddcf5307de7fc9c70f173e75aab4a12eb86abef0084084b5119f95326509ea665 SHA512 9c3761e7ce34f2d9d1b5ee49ebc3bf665e3d45e4146231bc77d7416801fbfa70415e80c81c64962897766ee068d1a103609895d783f20a765c351d4cd433323d
+DIST fdupes-2.2.1.tar.gz 144719 BLAKE2B 904fd70650847e48e135e47ef77e244ee847151f6ff88ccda2aeba5158038de8507b2ea23a7172e9c1fcd634ae38601c66da225014b9cfd65fd506ce77e7d408 SHA512 4911d2f776480691e7bd7045c181d49159add5b479188b05f0878a7af365cee0e430093e71ff172c04b876c58efc3be0f24c9d25f0cdebf1c869931175bc8608
+DIST fdupes-2.3.0.tar.gz 154700 BLAKE2B 0266920a124f210955fdcfd3e689db50f4dd8062c68f18f6e7d3bc35d7be7002e8088634253d37ebbb59fda5edb7c9642c5d7f0e8ade9c70cbd3067c3778d676 SHA512 7801538b84797af94a5e9300cf5605b775380b7eef05ea1f70a5c6a2521d09c66dc6f310316a062c241fcf2086def52dc24be42a336c4bcc8a450f8578d310fc
diff --git a/app-misc/fdupes/fdupes-2.1.2.ebuild b/app-misc/fdupes/fdupes-2.1.2.ebuild
deleted file mode 100644
index 8f97be90f133..000000000000
--- a/app-misc/fdupes/fdupes-2.1.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Identify/delete duplicate files residing within specified directories"
-HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
-SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="+ncurses"
-
-RDEPEND="
- dev-libs/libpcre2[pcre32]
- ncurses? ( sys-libs/ncurses:0= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( CHANGES CONTRIBUTORS README )
-
-src_configure() {
- econf $(use_with ncurses)
-}
-
-src_compile() {
- emake CC=$(tc-getCC)
-}
diff --git a/app-misc/fdupes/fdupes-2.2.1.ebuild b/app-misc/fdupes/fdupes-2.2.1.ebuild
new file mode 100644
index 000000000000..de6d94f0f316
--- /dev/null
+++ b/app-misc/fdupes/fdupes-2.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+ncurses"
+
+RDEPEND="
+ dev-libs/libpcre2[pcre32]
+ ncurses? ( sys-libs/ncurses:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES CONTRIBUTORS README )
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with ncurses)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
diff --git a/app-misc/fdupes/fdupes-2.3.0.ebuild b/app-misc/fdupes/fdupes-2.3.0.ebuild
new file mode 100644
index 000000000000..bbe30a2c963c
--- /dev/null
+++ b/app-misc/fdupes/fdupes-2.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+ncurses sqlite"
+
+RDEPEND="
+ dev-libs/libpcre2:=[pcre32]
+ ncurses? ( sys-libs/ncurses:= )
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES CONTRIBUTORS README )
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with ncurses) $(use_with sqlite)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
diff --git a/app-misc/fdupes/fdupes-9999.ebuild b/app-misc/fdupes/fdupes-9999.ebuild
index 9fc8d0597860..3578fdc09788 100644
--- a/app-misc/fdupes/fdupes-9999.ebuild
+++ b/app-misc/fdupes/fdupes-9999.ebuild
@@ -1,26 +1,27 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Identify/delete duplicate files residing within specified directories"
HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
-if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
+ inherit autotools git-r3
else
SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
+
LICENSE="MIT"
SLOT="0"
IUSE="+ncurses"
RDEPEND="
dev-libs/libpcre2[pcre32]
- ncurses? ( sys-libs/ncurses:0= )
+ ncurses? ( sys-libs/ncurses:= )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -29,7 +30,8 @@ DOCS=( CHANGES CONTRIBUTORS README )
src_prepare() {
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
@@ -37,5 +39,5 @@ src_configure() {
}
src_compile() {
- emake CC=$(tc-getCC)
+ emake CC="$(tc-getCC)"
}
diff --git a/app-misc/fdupes/metadata.xml b/app-misc/fdupes/metadata.xml
index 4a5652d5b09e..c045e6f3fbb5 100644
--- a/app-misc/fdupes/metadata.xml
+++ b/app-misc/fdupes/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>shell-tools@gentoo.org</email>