summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild')
-rw-r--r--app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild
new file mode 100644
index 000000000000..ded1d8f52689
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin/-/archive/release_${PV}/OpenRGBVisualMapPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBVisualMapPlugin-release_${PV}"
+KEYWORDS="amd64"
+
+DESCRIPTION="Plugin for OpenRGB to create virtual devices out of multiple real ones"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.9:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dep.patch"
+)
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+
+ # Because of -Wl,--export-dynamic in app-misc/openrgb, this resources.qrc
+ # conflicts with the openrgb's one. So rename it.
+ sed -e 's/resources.qrc/resources_visualmap_plugin.qrc/' -i *.pro || die
+ mv --no-clobber resources.qrc resources_visualmap_plugin.qrc || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBVisualMapPlugin.so.1.0.0
+}