summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/openrgb-plugin-visualmap')
-rw-r--r--app-misc/openrgb-plugin-visualmap/Manifest2
-rw-r--r--app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch18
-rw-r--r--app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.9-dep.patch17
-rw-r--r--app-misc/openrgb-plugin-visualmap/metadata.xml15
-rw-r--r--app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild47
-rw-r--r--app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild52
6 files changed, 151 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-visualmap/Manifest b/app-misc/openrgb-plugin-visualmap/Manifest
new file mode 100644
index 000000000000..3c2953eba128
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/Manifest
@@ -0,0 +1,2 @@
+DIST OpenRGBVisualMapPlugin-release_0.8.tar.bz2 51680 BLAKE2B c3423779f7a2082c8f682b519be2e1128b30dafbc4400414bd664f98de5c58701fbdbe9287a44951e8cf6ac4ee7c940a841f499ee1afce107e17537ad9df076b SHA512 7bf0393bc00bb69545ed02f6505f366aa90bb87350de6319977d02ba0afd38ccb895aa14edf02a42242b0a12f76ea2b135d8de5b3df10469c760b6f3d9dd2b61
+DIST OpenRGBVisualMapPlugin-release_0.9.tar.bz2 69646 BLAKE2B 2ae3c190c7b7347fadf62b4a133626da09e9ad90c1dc5c99decf960b115bff587e5d14d8e45ab65781171ebefdd29825422b9b709795d3d2cc735e8d0e061a69 SHA512 ef99263cbed900c1f541982e7349bda03212dfbb8873eb52db00f81cbe5823b7c4e2193de664dd7930da73e11a601b1b595b214629a813e1efda6e7184599521
diff --git a/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch b/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch
new file mode 100644
index 000000000000..b2023fa1df3a
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch
@@ -0,0 +1,18 @@
+--- a/OpenRGBVisualMapPlugin.pro
++++ b/OpenRGBVisualMapPlugin.pro
+@@ -96,7 +96,6 @@ HEADERS +=
+ OpenRGB/qt/hsv.h \
+
+ SOURCES += \
+- OpenRGB/RGBController/RGBController.cpp \
+ OpenRGBVisualMapPlugin.cpp \
+ VirtualController.cpp \
+ VisualMapSettingsManager.cpp \
+@@ -120,7 +119,6 @@ SOURCES +=
+ ui/widget-editor/EditorGrid.cpp \
+ ui/widget-editor/LedItem.cpp \
+ ui/widget-editor/WidgetEditor.cpp \
+- OpenRGB/qt/hsv.cpp \
+
+ FORMS += \
+ ui/BackgroundApplier.ui \
diff --git a/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.9-dep.patch b/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.9-dep.patch
new file mode 100644
index 000000000000..ce7b3824f950
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.9-dep.patch
@@ -0,0 +1,17 @@
+--- a/OpenRGBVisualMapPlugin.pro
++++ b/OpenRGBVisualMapPlugin.pro
+@@ -99,6 +99,5 @@ HEADERS +=
+ OpenRGB/qt/hsv.h \
+
+ SOURCES += \
+- OpenRGB/RGBController/RGBController.cpp \
+ OpenRGBPluginsFont.cpp \
+ OpenRGBVisualMapPlugin.cpp \
+@@ -124,7 +121,6 @@ SOURCES +=
+ ui/widget-editor/EditorGrid.cpp \
+ ui/widget-editor/LedItem.cpp \
+ ui/widget-editor/WidgetEditor.cpp \
+- OpenRGB/qt/hsv.cpp \
+
+ FORMS += \
+ ui/BackgroundApplier.ui \
diff --git a/app-misc/openrgb-plugin-visualmap/metadata.xml b/app-misc/openrgb-plugin-visualmap/metadata.xml
new file mode 100644
index 000000000000..7fac73257faa
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">OpenRGBDevelopers/OpenRGBVisualMapPlugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild
new file mode 100644
index 000000000000..29925e2a50ea
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin/-/archive/release_${PV}/OpenRGBVisualMapPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBVisualMapPlugin-release_${PV}"
+KEYWORDS="amd64"
+
+DESCRIPTION="Plugin for OpenRGB to create virtual devices out of multiple real ones"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.8:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dep.patch"
+)
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBVisualMapPlugin.so.1.0.0
+}
diff --git a/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild
new file mode 100644
index 000000000000..ded1d8f52689
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin/-/archive/release_${PV}/OpenRGBVisualMapPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBVisualMapPlugin-release_${PV}"
+KEYWORDS="amd64"
+
+DESCRIPTION="Plugin for OpenRGB to create virtual devices out of multiple real ones"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.9:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dep.patch"
+)
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+
+ # Because of -Wl,--export-dynamic in app-misc/openrgb, this resources.qrc
+ # conflicts with the openrgb's one. So rename it.
+ sed -e 's/resources.qrc/resources_visualmap_plugin.qrc/' -i *.pro || die
+ mv --no-clobber resources.qrc resources_visualmap_plugin.qrc || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBVisualMapPlugin.so.1.0.0
+}