summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pipeworks')
-rw-r--r--app-misc/pipeworks/files/pipeworks-0.4-makefile.patch26
-rw-r--r--app-misc/pipeworks/metadata.xml8
-rw-r--r--app-misc/pipeworks/pipeworks-0.4-r1.ebuild28
-rw-r--r--app-misc/pipeworks/pipeworks-0.4-r2.ebuild26
4 files changed, 56 insertions, 32 deletions
diff --git a/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch b/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch
new file mode 100644
index 000000000000..8a52d158b0e4
--- /dev/null
+++ b/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch
@@ -0,0 +1,26 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,21 +18,11 @@
+ # along with pipeworks; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+-CC= gcc -Wall
++CFLAGS += -Wall
+
+ all: pipeworks
+
+-filesize.o: Makefile filesize.h filesize.c
+- $(CC) -c -o filesize.o filesize.c
+-
+-timemanip.o: Makefile timemanip.h timemanip.c
+- $(CC) -c -o timemanip.o timemanip.c
+-
+-pipeworks.o: Makefile pipeworks.c filesize.h
+- $(CC) -c -o pipeworks.o pipeworks.c
+-
+-pipeworks: pipeworks.o filesize.o timemanip.o
+- $(CC) -o pipeworks pipeworks.o filesize.o timemanip.o
++pipeworks: filesize.o timemanip.o
+
+ clean:
+ rm -f *.o *~ pipeworks
diff --git a/app-misc/pipeworks/metadata.xml b/app-misc/pipeworks/metadata.xml
index 152b5b0e4983..5852e04da2a1 100644
--- a/app-misc/pipeworks/metadata.xml
+++ b/app-misc/pipeworks/metadata.xml
@@ -3,10 +3,10 @@
<pkgmetadata>
<!-- maintainer-needed -->
<longdescription>
-pipeworks is a benchmarking tool for pipelines that is very similar to pipemeter. It writes its stdin to its
-stdout, while reporting the data flow rate to stderr. It features adjustable block size and bandwidth limiting
-capabilities.
-</longdescription>
+ pipeworks is a benchmarking tool for pipelines that is very similar to pipemeter. It writes its stdin to its
+ stdout, while reporting the data flow rate to stderr. It features adjustable block size and bandwidth limiting
+ capabilities.
+ </longdescription>
<upstream>
<remote-id type="sourceforge">pipeworks</remote-id>
</upstream>
diff --git a/app-misc/pipeworks/pipeworks-0.4-r1.ebuild b/app-misc/pipeworks/pipeworks-0.4-r1.ebuild
deleted file mode 100644
index 28c0a7a154e0..000000000000
--- a/app-misc/pipeworks/pipeworks-0.4-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="A small utility that measures throughput between stdin and stdout"
-HOMEPAGE="http://pipeworks.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pipeworks/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-src_compile() {
- emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
-}
-
-src_install() {
- dobin pipeworks
- doman pipeworks.1
- dodoc Changelog README
-}
diff --git a/app-misc/pipeworks/pipeworks-0.4-r2.ebuild b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
new file mode 100644
index 000000000000..ce8e9f948f5d
--- /dev/null
+++ b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small utility that measures throughput between stdin and stdout"
+HOMEPAGE="https://sourceforge.net/projects/pipeworks/"
+SRC_URI="https://downloads.sourceforge.net/pipeworks/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin pipeworks
+ doman pipeworks.1
+ dodoc Changelog README
+}