summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ttysnoop/files/ttysnoop-makefile.patch')
-rw-r--r--app-misc/ttysnoop/files/ttysnoop-makefile.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-misc/ttysnoop/files/ttysnoop-makefile.patch b/app-misc/ttysnoop/files/ttysnoop-makefile.patch
deleted file mode 100644
index ba8d702e9e6e..000000000000
--- a/app-misc/ttysnoop/files/ttysnoop-makefile.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2,8 +2,6 @@
- # Makefile for the ttysnoop programs
- #
-
--CC = gcc
--
- # Without shadow support
-
- #CCOPTS = -O2
-@@ -11,7 +9,7 @@
-
- # For shadow support
-
--CCOPTS = -O2 -DSHADOW_PWD
-+CCOPTS = -DSHADOW_PWD
- LIBS = -lcrypt
- #LIBS = -lshadow
-
-@@ -24,19 +22,19 @@
- all: ttysnoops ttysnoop
-
- ttysnoops: $(SERVEROBJS)
-- $(CC) $(SERVEROBJS) -o ttysnoops $(LIBS)
-+ $(CC) $(LDFLAGS) $(SERVEROBJS) -o ttysnoops $(LIBS)
-
- ttysnoop: $(CLIENTOBJS)
-- $(CC) $(CLIENTOBJS) -o ttysnoop $(LIBS)
-+ $(CC) $(LDFLAGS) $(CLIENTOBJS) -o ttysnoop $(LIBS)
-
- ttysnoops.o: $(SERVERSRCS) $(INCLUDES)
-- $(CC) $(CCOPTS) -c -o ttysnoops.o $(SERVERSRCS)
-+ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o ttysnoops.o $(SERVERSRCS)
-
- ttysnoop.o: $(CLIENTSRCS) $(INCLUDES)
-- $(CC) $(CCOPTS) -c -o ttysnoop.o $(CLIENTSRCS)
-+ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o ttysnoop.o $(CLIENTSRCS)
-
- common.o: common.c common.h
-- $(CC) $(CCOPTS) -c -o common.o common.c
-+ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o common.o common.c
-
- clean:
- rm -f *.o core ttysnoop ttysnoops