summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ttysnoop/files')
-rw-r--r--app-misc/ttysnoop/files/pinkbyte_masking.patch41
-rw-r--r--app-misc/ttysnoop/files/ttysnoop-makefile.patch45
2 files changed, 0 insertions, 86 deletions
diff --git a/app-misc/ttysnoop/files/pinkbyte_masking.patch b/app-misc/ttysnoop/files/pinkbyte_masking.patch
deleted file mode 100644
index 8d944b21e3af..000000000000
--- a/app-misc/ttysnoop/files/pinkbyte_masking.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/ttysnoops.c
-+++ b/ttysnoops.c
-@@ -18,6 +18,7 @@
- v0.12d 8-4-98 Carl Declerck - updated #includes a bit
- k26 28-5-00 Vinicius Anselmo - added sound alert (demoniac) created by Stas
- k26 31-5-04 Vinicius Anselmo - updated for unix98 pty support
-+ k26 13-8-09 Pinkbyte - deleted fucking sound alert and "bye bye" message ;)
- */
-
- #include <sys/types.h>
-@@ -502,22 +503,6 @@
- struct utmp utmp;
- int ptyfd, servfd, len, n, sel, susp = 0;
-
-- /* demoniac begin */
--
-- StopHandle();
--
-- if (InitSound()) /* play if we can */
-- {
-- DoSound(466, SLEN); // A#4
-- DoSound(622, SLEN); // D#5
-- DoSound(784, SLEN); // G5
-- DoSound(932, SLEN*2); // A#5
-- DoSound(784, SLEN); // G5
-- DoSound(932, SLEN*3); // A#5
-- }
--
-- /* demoniac end */
--
- if (!isatty(STDIN_FILENO))
- errorf ("stdin is not a tty\n");
-
-@@ -660,7 +645,6 @@
- {
- if ((n = read(ptyfd, buff, BUFF_SIZE)) < 1)
- {
-- errorf ("bye bye\n");
- exit (0);
- }
-
diff --git a/app-misc/ttysnoop/files/ttysnoop-makefile.patch b/app-misc/ttysnoop/files/ttysnoop-makefile.patch
deleted file mode 100644
index ba8d702e9e6e..000000000000
--- a/app-misc/ttysnoop/files/ttysnoop-makefile.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2,8 +2,6 @@
- # Makefile for the ttysnoop programs
- #
-
--CC = gcc
--
- # Without shadow support
-
- #CCOPTS = -O2
-@@ -11,7 +9,7 @@
-
- # For shadow support
-
--CCOPTS = -O2 -DSHADOW_PWD
-+CCOPTS = -DSHADOW_PWD
- LIBS = -lcrypt
- #LIBS = -lshadow
-
-@@ -24,19 +22,19 @@
- all: ttysnoops ttysnoop
-
- ttysnoops: $(SERVEROBJS)
-- $(CC) $(SERVEROBJS) -o ttysnoops $(LIBS)
-+ $(CC) $(LDFLAGS) $(SERVEROBJS) -o ttysnoops $(LIBS)
-
- ttysnoop: $(CLIENTOBJS)
-- $(CC) $(CLIENTOBJS) -o ttysnoop $(LIBS)
-+ $(CC) $(LDFLAGS) $(CLIENTOBJS) -o ttysnoop $(LIBS)
-
- ttysnoops.o: $(SERVERSRCS) $(INCLUDES)
-- $(CC) $(CCOPTS) -c -o ttysnoops.o $(SERVERSRCS)
-+ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o ttysnoops.o $(SERVERSRCS)
-
- ttysnoop.o: $(CLIENTSRCS) $(INCLUDES)
-- $(CC) $(CCOPTS) -c -o ttysnoop.o $(CLIENTSRCS)
-+ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o ttysnoop.o $(CLIENTSRCS)
-
- common.o: common.c common.h
-- $(CC) $(CCOPTS) -c -o common.o common.c
-+ $(CC) $(CCOPTS) $(CPPFLAGS) $(CFLAGS) -c -o common.o common.c
-
- clean:
- rm -f *.o core ttysnoop ttysnoops