summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/psiconv/psiconv-0.8.3-r1.ebuild')
-rw-r--r--app-text/psiconv/psiconv-0.8.3-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/psiconv/psiconv-0.8.3-r1.ebuild b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..8c54d544d899
--- /dev/null
+++ b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="An interpreter for Psion 5(MX) file formats"
+HOMEPAGE="http://huizen.dds.nl/~frodol/psiconv"
+SRC_URI="http://huizen.dds.nl/~frodol/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="static-libs"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+src_prepare() {
+ tc-export AR
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm -fr "${D}"usr/lib*/lib${PN}.la
+}