summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/psiconv')
-rw-r--r--app-text/psiconv/Manifest1
-rw-r--r--app-text/psiconv/metadata.xml8
-rw-r--r--app-text/psiconv/psiconv-0.8.3-r1.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/app-text/psiconv/Manifest b/app-text/psiconv/Manifest
new file mode 100644
index 000000000000..f6a4f6491ee1
--- /dev/null
+++ b/app-text/psiconv/Manifest
@@ -0,0 +1 @@
+DIST psiconv-0.8.3.tar.gz 326460 SHA256 4fec0d7c1d18f593e9a90a7dc08d84489aa92828849bd4ff393eab20f44543b8 SHA512 a48814f64fd2c3dda0dfa13c331d2d60ff8674ab7a56f51efcad29d3dd6874f4b94dc0a21ef3066b0fa605b18635ee151fbb4e3eeb06dab3854a329ed70348a9 WHIRLPOOL 79e024d60c8621dcc8a36cba29109d358241ecff3dd3fec38c32d0b187c03ba947a7d8495bf384ebe3e87efda89e170315da1ab8952dba0b03232980a026373b
diff --git a/app-text/psiconv/metadata.xml b/app-text/psiconv/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/app-text/psiconv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/psiconv/psiconv-0.8.3-r1.ebuild b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..8c54d544d899
--- /dev/null
+++ b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="An interpreter for Psion 5(MX) file formats"
+HOMEPAGE="http://huizen.dds.nl/~frodol/psiconv"
+SRC_URI="http://huizen.dds.nl/~frodol/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="static-libs"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+src_prepare() {
+ tc-export AR
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm -fr "${D}"usr/lib*/lib${PN}.la
+}